UE 4.10.1 tells you to install VS2013 when VS2015 is not installed


Hey EnricoUniverse-

Could you explain where you saw this message? Did this appear when creating a new project. You mentioned not having VS2015, did you have VS2013 when you received this message?

I have also encountered this exact message when attempting to package the project for Windows 32/64 even though VS 2013 is installed.

Installing VS 2015 resolved this error.

I don’t know who keeps accepting this comment as an answer while the bug is still not fixed. Like this guy said, installing VS2015 hides the missing VS2013 notification, which is EXACTLY what this bug report is about.

UE 4.10.1 shouldn’t ask for VS2013 when VS2015 is missing when packaging a project.

VS2013 isn’t even supported in 4.10 IIRC.

It’s probably just something that just didn’t get updated. So visually yes it’s wrong and should be changed, but the solution is still correct.

Hey EnricoUniverse-

Could you let me know where you’re seeing this error? Knowing where to look for the incorrect message will help us find where the exact problem is and lead to how best to fix it.

I’ve already commented on this before but my comment apparently got lost because of the server issues. This happens when packaging a game.

I’ve uninstalled VS2015 (and 2013) and did not get the error message you mentioned when packaging for Windows (32 & 64 - Development & shipping). Could you list the steps that reproduce this problem for you in a new project? Also, do you have VS2013 installed or do you not have Visual Studio installed at all?

My comment got eaten up again by the server issues; I had VS2013 installed, not VS2015 and tried to package my game. That’s it.

I have entered a bug report to update the VS version of the message when attempting to package without VS2015 (UE-24641).


Just noting that VS2013 is supported in 4.10. That doesn’t change that the issue above is still a bug though.

This was fixed in CL 2890185.