Download

[UE 4.10.1] Provision and Signing Key not Found (Mac 10.10.5)

As the title implies, I can’t sign my game on a Mac 10.10.5 as it keeps telling me that it can’t find my provisioning or certificate.

I have installed the certificate to the login key chain, even made it freely accessible without password request and I also made sure that all folders are as they should be as well as checked everything pretty much 3-4 times.
I keep getting the same error regardless of what I do. I can even see both in the overview of the UE4 IOS settings and they are set as valid.

I have been trying to get this to work for about 5-6 days now without luck. I cannot launch my game on the iOS platform at this rate which will cut my revenue stream in half :confused:
I have looked at all the tutorials you got as well as followed various threads on the forum but most of them are about PC and doesn’t even apply to Mac (I tried).

So what do I do exactly? I need to release my game this month. At this rate I will have to “settle” for Android only.

Okay so, I went into ./Users/Username/Library/MobileDevices/Provision Profiles/ and added the provisioning profile and certificate myself in that folder, which is where Unreal Engine 4 looks for these things. Now it still tells me that it can’t find either of the Provisioning Profile or the matching Certificate however the log tells me that it found both.

It cooks the build just fine but then when it starts packaging it fails right at the “Signing the code” part and then won’t complete the build.

Hi Vipar,

Just a few questions to hopefully narrow down why it’s not able to sign. We also want to be able to clarify the iOS quick start and other provisioning info, to make this process smoother for you and everyone else going forward. :slight_smile:

  • What version of XCode are you using?
  • Did you add the certificate and provision with the import buttons in the iOS project settings, or by manually copying them?
  • Is this a wildcard provision or a provision with a Bundle ID specified?
  • Does your project have specialized mobile features like IAP, leaderboards, achievements, etc?

Thanks!

  • The Project is Pure Blueprint. No use of XCode.
  • I have tried both copying them myself and to use the import buttons. Doing it manually made the engine find the two when packaging but using Import made it fail to find either when packaging. However in both cases the engine claims to be unable to find either before you start packaging.
  • I have tried both a Wildcard and a Bundle ID and both have the same results of failing when about to package the project.
  • Yes it uses IAP, Leaderboards and Achievements.

Vipar,

I am currently assisting you on AnswerHub. Please update information there as it comes available.

Thank you!