Download

UE 4.0.2 build tool makes me crazy :(

First of all i still has subscribe button instead download button in launcher, so i use only sources from github.

  1. In Beta shell command “generate project files” worked fine, and it generated VS solution, where only was one project without engine.

  2. When comes UE 4.0.1 then shell command “generate project files” was not working for me same way as people wrote on answer hub.
    When i tried to create new project with sources from editor, then it works fine, but it generated VS solution with 2 projects: UE and mine one.
    If i tried to manually run command line RocketGenerateProjectFiles.bat with full names to batch file and project file - then VS solution looked like i beta - it had only one mine project in solution tree without UE4 sources.

  3. Then comes UE 4.0.2 :frowning:
    Shell commands in this version was fixed, and it generates project files fine. But now generated solution file always have UE project, mine project and programs in solution tree.
    And all my problems starts from that moment.
    When i am trying to clean project - it also cleans UE4 engine project. Even if i am chosing Project only -> Clean only mine project.
    When i am trying to build or rebuild mine project - it also rebuilds UE4 engine project. Even if i am chosing Project only -> Rebuild only mine project.
    So, every little change in mine project sources will rebuild engine also. And it is a real hell to wait more than 4 hours after you make few changes while project and engine will be built.

I do not understand why UE4 build tool cleans engine, rebuld engine every time i make changes only in mine project.

What i am doing wrong? Or what happened with build tool? Or how to setup VS solution to prevent this issue?

just found another same issue thread here

is this batch solution generation bug? or it is VS bug, which is suddenly appears only on UE 4.0.2?

Hi h2o,

Hello! Please report your bug on the UE4 Answerhub in the Bug Reports section. This will help us to investigate and track the issue.
Also, please see this post for additional information that could prove useful.

there is one already:
https://answers.unrealengine.com/questions/17131/problem-the-engine-compiles-every-time-we-do-chang.html
but it is not in “Bug Reports” section

**Adam Davis ** please can you transfer it to right section that Epic Games can test and fix that reason?

Today i spent much time to investigate what is the mysterious reason of solution generation difference between beta and release versions. And i have got interesting result
1. In Beta shell command “generate project files” worked fine, and solution project properties had:

2. in UE 4.0.1 from github \Engine\Build\BatchFiles\RegisterShellCommands.bat did not worked properly, so shell command “generate project files” did not worked. And i used commandline command to generate project files:

This command generated solution file with same project properties as was in beta, so build, rebuild and clean works fine.
Also RocketGenerateProjectFiles.bat generates files with command:

As you can see here is parameter option -rocket

3. in UE 4.0.2 from github \Engine\Build\BatchFiles\RegisterShellCommands.bat was fixed and now it works fine and it generates project files.
But now solution tree in VS have UE4 sources, tools and project, additional build options.
And as i wrote above, any code changing will start engine recompilation.
“Rescan project folder” suggestion from this thread: Problem: The engine compiles every time we do changes to our project - C++ Gameplay Programming - Unreal Engine Forums helps, but it is not a good way to do it after every code change. Also project scans starts automatically after i open VS, but i should do rescan any way.
Shell command “generate project files” run

GenerateProjectFiles.bat generates files with command:

So, as you can see it has no -rocket parameter
Also generated solution project properties now contain:

There is no UE_ROCKET=1 and -rocket parameters options.

4. UE 4.0.2 installed from launcher (binary version)
In this version shell command “generate project files” worked fine, and solution project properties had:

so, it is same as in Beta and when you use RocketGenerateProjectFiles.bat and different that solution generated by GenerateProjectFiles.bat.

So, for now, i am still using RocketGenerateProjectFiles.bat to generate solution which not recompiles engine at every code changing.