UDP Transport causes stuttering in 4.24, UE-86170

Hello all! A few weeks ago I migrated a project to 4.24, and started getting an issue where I would get a stutter every 3 seconds or so. I did a quick Google search and found someone with the same problem and they had to disable UDP Transport in Project Settings to get rid of the stuttering. This also works for me, however I since had started a new project, did not have the problem, then this morning I turned on my laptop and discovered that my new project now has this issue, when previously it did not… Anyone have any information on this? I am filing a bug report now.

Edit: Luckily my game is not going to be online, however I would like to know the cause of this.

Edit2: I think I found a bug report of this issue already, however it says “Won’t Fix” What the heck does that mean? They are just going to ignore it??

1 Like

Thanks for the help… Guess I will never know

I posted this a while back, still having the same issue if 4.25.1… Anyone have any info on this?

I also have this problem and from a reddit post:

I can confirm that for my case it seems to simply be due to the fact that I have a VPN installed (PIA).

Unreal Engine only stutters when I am is NOT connected to the VPN.

So either connect to your VPN if you have one, or uncheck “Enable Transport” in UDP Messaging Project Settings in the meantime I suppose.

I too saw that post, however I am not using VPN. I noticed that if I am using wifi, I have this issue. If I am using ethernet, I do not…

I started to get this issue recently, I believe since Windows 10 force-updated to 2004 version. I disabled all the network devices, re-enabled them again, uninstalled Logmein Hamachi and the problem went away.

1 Like

After booting my PC

    1. if I connect to a VPN before launching a project (blank or custom), I get no stuttering
  • after 1, disconnecting from the VPN will cause the stuttering on any project - blank or custom.

  • reconnecting to the VPN will fix it.

  • rebooting my PC generally fixes it, but I think the stuttering will reoccur if I change connections after launching a project

  • unchecking Enable Transport will fix it. OR unchecking Auto Repair will fix it.

Another, perhaps better, way to fix it is to disable Send Usage Data in Editor Preferences. Since I need multiplayer, disabling Send Usage Data is the best fix for me.

p.s. some cool person on Unreal Slackers told me about the Send Usage Data setting.

1 Like

Great to see there are finally ways to fix this other than just disabling transport like I previously did. And I do still have this issue on 4.27.1, only when using wifi.

I don’t have a vpn, nor am i connected to wifi but i’m still getting this issue and it’s driving me insane. what if i need that plugin to create a multiplayer game… it’s happening to me on 4.27.2 and it started happening to me within the last 4 months for absolutely no reason

Had this happen in 4.27 AND UE 5.0.
Disabling UDP transport worked.
Also, disabling the LogMeIn Hamachi network adapter in Windows worked without having to disabled UDP transport.

Thanks for the information.