UDK Freezing whenever right click content browser

Hello guys!

I am having a very weird problem, from since yesterday. I think it may have to do with my PC. Now UDK crashes each time I right click on content browser. I tried to change to list view, however it works, however whenever I click on content browser, my cpu usage goes to 100% then it freezes.

Here is my log, nothing wrong:

Log: Log file open, 10/08/18 10:11:39
Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
Init: Version: 8364
Init: Epic Internal: 0
Init: Compiled (32-bit): Oct 8 2018 03:06:29
Init: Changelist: 871961
Init: Command line: editor -log
Init: Base directory: D:\AnaIrhabiGame\Binaries\Win32
DevConfig: GConfig::LoadFile associated file: …\UDKGame\Config\UDKCompat.ini
[0000.70] Init: Computer: NIDAL
[0000.70] Init: User: Nidal
[0000.70] Init: CPU Page size=4096, Processors=8
[0000.70] Init: High frequency timer resolution =1.562617 MHz
[0000.70] Init: Memory total: Physical=7.9GB Pagefile=19.8GB Virtual=4.0GB
[0000.70] Log: STEAMWORKS initialized 0
[0000.73] Init: WinSock: I am nidal (
[0000.73] Init: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
[0000.73] Init: Object subsystem initialized
[0016.31] DevDataBase: Failure trying to open connection [Provider=sqloledb;Data Source=production-db;Initial Catalog=EngineTaskPerf;Trusted_Connection=Yes;Connection Timeout=2] [Atributo na cadeia de ligação inválido]
[0016.31] DevDataBase: Connection to “Provider=sqloledb;Data Source=production-db;Initial Catalog=EngineTaskPerf;Trusted_Connection=Yes;Connection Timeout=2” or “” failed
[0016.31] DevDataBase: Failure closing connection [A operação não é permitida se o objecto estiver fechado.]
[0016.36] Log: Shader platform (RHI): PC-D3D-SM3
[0017.56] Log: PhysX GPU Support: DISABLED
[0017.56] Init: Initializing FaceFX…
[0017.56] Init: FaceFX 1.7.4 initialized.
[0021.13] Log: Missing cached shader map for material v_rpg7_lit, compiling.
[0023.23] Log: Missing cached shader map for material v_rpg7, compiling.
[0024.73] Log: Missing cached shader map for material ak47mat, compiling.
[0026.09] Log: Missing cached shader map for material Material_0, compiling.
[0027.23] Log: Missing cached shader map for material v_makarov, compiling.
[0028.73] Init: Finished loading startup packages in 10.93 seconds
[0028.74] Log: 77556 objects as part of root set at end of initial load.
[0028.74] Log: 0 out of 0 bytes used by permanent object pool.
[0028.84] Log: Supported Consoles:
[0028.84] Log: PS3
[0028.84] Log: PC
[0028.84] Log: Xbox360
[0028.84] Log: Initializing Engine…
[0028.95] Log: Encountered missing default brush - spawning new one
[0028.95] Init: UEngine initialized
[0028.95] Log: Primary PhysX scene will be in software.
[0028.95] Log: Creating Primary PhysX Scene.
[0028.96] Init: Transaction tracking system initialized
[0029.79] Log: Missing cached shader map for material palestine_hero_1_color, compiling.
[0031.31] Log: Missing cached shader map for material backpack_frame_color, compiling.
[0032.78] Log: Missing cached shader map for material backpack_color, compiling.
[0034.19] Log: Missing cached shader map for material backpocket_color, compiling.
[0035.50] Log: Missing cached shader map for material marine_v3, compiling.
[0036.90] Log: Missing cached shader map for material eyes, compiling.
[0038.24] Log: Missing cached shader map for material palestine_attachments_color, compiling.
[0039.80] Log: Missing cached shader map for material eye, compiling.
[0041.09] Log: Missing cached shader map for material LEns, compiling.
[0042.44] Log: Missing cached shader map for material marine_a_head, compiling.
[0043.76] Log: Missing cached shader map for material marine_v3_attachments, compiling.
[0045.20] Log: Missing cached shader map for material new_marine_arms, compiling.
[0046.58] Log: Missing cached shader map for material Diff00, compiling.
[0047.99] Init: XAudio2 using ‘Altifalantes (Realtek High Definition Audio)’ : 2 channels at 48 kHz using 32 bits per sample (channel mask 0x3)
[0048.10] Log: Working around XDK XAudio2 regression: TRUE
[0048.11] Init: XAudio2Device initialized.
[0048.21] Log: WinTab initalized successfully.
[0048.21] Init: Client initialized
[0048.21] Init: Editor engine initialized
[0048.36] Log: Initializing Engine Completed
[0048.36] Log: >>>>>>>>>>>>>> Initial startup: 48.36s <<

Here is a screenshot whenever UDK Editor Freezes. This is driving me nuts !!! :(:(:frowning:

This is happening with both 32bits and 64bits UDKGame.exe

Any ideas???

your log is getting cut so its impossible to get any hints from it. sometimes the logs get cut and other times they dont. maybe post a log that shows more stuff at the end (something that indicates an error or crash)

also is the crash happening at any time you right click it, or only from a certain folder?
maybe also, did this maybe start happening after adding new code to a (unrealscript) class?

Looks like this is happening when you are doing a right click in your own created folder AK47.It tries to load a package that most probably experienced a save fail when you last edit it.If you do a right click in a normal udk stock folder and it doesn’t crash, than the problem lies in your last saved package.
Also you can try to delete the udkengine.ini from the config folder,recompille and see if that helps.(the udkengine.ini shoud be created automatically again)

I thought you were from the middle east.Your windows looks to be in something similar to Spanish language? Just curious :smiley:

Hello guys! Thanks for the fast response folks!!!

After spending many hours thinkering with that, I already found a solution, now, it is working normal, it’s not freezing anymore.

I think my Notebook is getting old, it’s a bit dated :slight_smile:

I have a ASUS ROG G60JX from 2010 with 8GB Ram and 1GB Nvidia GTS 360M (8 years for a pc is a bit old), and I realized it is struggling with performance hickups on UDK and other apps (Photoshop, After Effects). What I realized is that sometimes whenever I am playtesting something in UDK, it randomly goes to 100% CPU and memory usage, making some random freezing by some seconds.

So what I have done, I first of all resintalled the latest Nvidia Driver for my GPU, then I did increase the virtual memory on Windows Advanced Settings to 16GB. As we know, Virtual Memory does not increase performance itself, however it is good if to prevent out-of-memory conditions that can crash the app, and I think this is what was hapenning in UDK.

I will hope that this problem got solved trully.


Hello dude, off course feel free to ask anything about me! :smiley: I am from Brazil, however my parents are immigrant from Palestine. My wife is from Morocco :smiley:

My windows is in Portuguese Language, however is not portuguese BR, is portuguese PT, because I purchased it from Paraguay, and the international Portuguese Language is Portuguese from Portugal, although the differences are minor between them.

I plan to make my game in Arabic, English and Portuguese language aswell (the three main languages I know and speak).


Hello guys!

It’s me again here, unfortunatelly, UDK came back to freezing. I don’t know if that maybe a problem with some windows component, I think maybe Net Framework reinstall can solve it, however, before trying and waste my time, I did use Windows Debug Tools to try to find what is happening.

However as I am not a programmer, I will post the debugger log here to see if someone which more programming experience can help me:


Finally I solved the problem, after too much distress and headaches.

By analysing the debug log, I came to this statement

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Windows\Microsoft.NET\Framework64\v3.0\WPF\wpfgfx_v0300.dll - 
00000000`0052db70 00000000`66e291af KERNELBASE!WaitForSingleObjectEx+0x9c
00000000`0052dc10 00000000`66e2a293 wpfgfx_v0300!MilGlyphRun_SetGeometryAtRenderTime+0xd57

So I did a google search on this term

wpfgfx_v0300 MilGlyphRun_SetGeometryAtRenderTime

And voila!!! I came across this article:

This solved my problem!!!

UDK Content Browser uses WPF (Windows Presentation Foundation) which is a component of Microsoft Net Framework to draw the text and hover effects whenever we position the mouse over some package, or right-click.

So simply the Windows Presentation Foundation Font Cache on my PC was corrupted, I just had to delete it, then UDK came back to work flawlessly!!!

Cheers :smiley: