Download

UCX collision mesh importing incorrectly

Hey guys,

Haven’t used UE4 since version 4.12, so maybe something has changed. I wasn’t having problems with UCX imports before (maybe I’m forgetting something?).

I’ve been trying to import my collision mesh. See below for my Modo setup. No concave shapes, nothing overlapping. Labeled correctly. When I import to UE4, it is simplifying the collision mesh - filling in the concave area even though in my Modo model each shape is separate (again, see below).

Do I have to change some some import settings I am forgetting about? Has something changes since I last used UE4. This method worked fine for me in the past.

SOLVED: For anyone looking for this solution, uncheck “One Convex Hull Per UCX” under the mesh’s import settings.

1.jpg

8530088f67ffcc064dc1d65916d3f8e1f585c0c0.jpeg