Ubuntu UE4Editor build failure, what may be the issue?

I’m trying to build UE4 from source, the release version on:

  • Ubuntu 18.04 LTR (lxde (lubuntu))
  • gcc-6 and gcc-7 (same error on both tries)
  • AMD A6-6400K APU
  • GeForce GTX 1080
  • 8 GB ram
  • cuda 9.1

The build took a lot of time (hours) until failing. I’ve tried it the last few days about 4 or 5 times already, both on ubuntu 16.04 LTR and on 18.04. About two years ago, it built successfully and ran flawless from first try, but i had a different hardware setup.

the error is:

ERROR: UBT ERROR: Failed to produce item: /home/feral/unrealEngine4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-MovieSceneCaptureDialog.so
(see …/Programs/UnrealBuildTool/Log.txt for full exception trace)
Total build time: 12834.43 seconds (Local executor: 0.00 seconds)
Makefile:188: recipe for target ‘UE4Editor’ failed
make: *** [UE4Editor] Error 5

the log is:

ActionThread.ThreadFunc: [1579/1592] Link (ld) libUE4Editor-BlankPlugin.so
ActionThread.ThreadFunc: [1580/1592] Link (ld) libUE4Editor-PythonScriptPluginPreload.so
ActionThread.ThreadFunc: [1581/1592] Link (ld) libUE4Editor-UE4Game.so
ActionThread.ThreadFunc: [1582/1592] Link (ld) libUE4Editor-XGEController.so
ActionThread.ThreadFunc: [1583/1592] Link (ld) libUE4Editor-IPC.so
ActionThread.ThreadFunc: [1584/1592] Link (ld) libUE4Editor-Advertising.so
ExceptionUtils.m__1: ==============================================================================
ExceptionUtils.m__0: ERROR: UBT ERROR: Failed to produce item: /home/feral/unrealEngine4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-MovieSceneCaptureDialog.so
ExceptionUtils.m__0: (see …/Programs/UnrealBuildTool/Log.txt for full exception trace)
ExceptionUtils.m__1: BuildException: UBT ERROR: Failed to produce item: /home/feral/unrealEngine4/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-MovieSceneCaptureDialog.so
ExceptionUtils.m__1: at UnrealBuildTool.ActionGraph.ExecuteActions (UnrealBuildTool.BuildConfiguration BuildConfiguration, System.Collections.Generic.List`1 ActionsToExecute, Boolean bIsRemoteCompile, System.String& ExecutorName, System.String TargetInfoForTelemetry, EHotReload HotReload) [0x00000] in :0
ExceptionUtils.m__1: at UnrealBuildTool.UnrealBuildTool.RunUBT (UnrealBuildTool.BuildConfiguration BuildConfiguration, System.String[] Arguments, Tools.DotNETCommon.FileReference ProjectFile, Boolean bCatchExceptions) [0x00000] in :0
ExceptionUtils.m__1: ==============================================================================
UnrealBuildTool.RunUBT: Total build time: 12834.43 seconds (Local executor: 0.00 seconds)

What may be the issue? thanks

^ _ ^

Hey, couple questions.

Why the master branch and not Release or 4.20? - Master might have issues that are yet to be resolved, also it is not recommended to be developing anything on it as things are prone to break and change there.

Did you do all the required steps? A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

I am not sure about gcc support, current versions of the engine do carry the entire toolchain with it so that should not even matter.