Ubuntu 18.04 initializing stuck on 18%

Hello everyone, today I decided to install Unreal Engine on ubuntu 18.04 and ran into a problem. I didn’t find a solution on the Internet, so I hope to find help here. After installing Unreal Engine according to official documentation, I tried to run UE4Editor but initializing stuck on 18 percent and doesn’t move.
Maybe someone has already encountered a similar problem and can advise something?

Intel Xeon Processor E5-2640
8 Gb RAM
GeForce GTX 650 2gb
SSD 250 Gb

-экрана-от-20200217-193236.jpg

I was reading up on linux and unreal, it is possible to get them working together : just a warning about the “initial” load, it takes something like 20 minutes + on your first load, after that it only takes 1min,

because on your first load, it is doing a lot of “compiling”,

but I don’t know if that’s the case in your situation, I would let it try to load for a hour or so just incase.

I am going to provide a link to a guide on how to get Linux up and running :

Run Unreal Engine 4 on Ubuntu 16.04 | The Ubuntu Addict

so if your install doesn’t work, you have another option to get Linux and unreal up and running.

God Bless you. May Jesus Christ be Charitable unto you.

Acts 10 : 33 - 48, google it, its Awesome.

Dear @Xios1337

I had the same problem yesterday. After some inspection, it turned out that the RAM memory was maxed out.
The first time Unreal Engine runs, it needs to setup some stuff for future usage (e.g. compiling about 5000 shaders).
This requires a very large memory to successfully complete. There are 2 solutions:

  • The expensive way: Buy and install extra RAM memory
  • The easy way: Increase your virtual memory by using a swap space

A swap space lets us use part of the hard disk to act as RAM memory. This is very handy in case of emergency.
If you choose the easy way, here is how to do it. Open a terminal window and run the following commands.



sudo fallocate -l 10G /swapfile
sudo chmod -c 600 /swapfile
sudo mkswap /swapfile
sudo swapon -v /swapfile


Notice the **10G **in the first command. I didn’t know how much memory was needed, so I used a 10 Gigabyte swap file.
This may be unnecessary, you can reduce that to 8G. Make sure you have enough free space on the root partition.

To complete the final step of installing Unreal, open the Unreal Engine installation folder in the terminal:



cd Engine/Binaries/Linux
./UE4Editor


It will keep running for some time, wait until the Unreal Editor opens.
Then it will begin installing shaders (about 5000), wait until the count-down in the bottom-right corner finishes.
Congratulations, Unreal is finally installed.

N. B.
Normally, the swap space will be turned off when you shutdown or restart.
After restart, if you want to turn it on again, run:



sudo swapon -v /swapfile


Since Unreal Engine is very memory-hungry, It is safer to keep using the swap file.
To make the swap file automatically turn on every time you open the computer, run the command:



echo '/swapfile  none  swap  defaults  0  0' | sudo tee -a /etc/fstab


Instead, if you prefer to get rid of the swap file, run this:



sudo swapoff -a
sudo rm -v /swapfile


1 Like

make sure you do the swap stuff mentioned above, then you close every software on your computer (including any web browsers) and only keep a terminal opened, then open the engine and keep up with it even if it got stuck, eventually it will initialize itself.