UBT Error (Failed to produce item) when compiling from source - 3 succeeded, 1 failed

I’m trying to compile from source for the first time, using the release branch. I went through all of the necessary steps as listed on the official GitHub page and received this as an error when attempting to build the UE4 solution. As this folder is located in my Program Files directory, I made sure to open Visual Studio as Administrator before I tried to build. Any help with this would be appreciated!

4>  [2269/2502] Module.UnrealEd.18_of_21.cpp
4>UnrealBuildTool : error : UBT ERROR: Failed to produce item: C:\Program Files\Epic Games\UnrealEngine\Engine\Intermediate\Build\Win64\UE4Editor\Development\UnrealEd\UE4Editor-UnrealEd.lib
4>                        (see ../Programs/UnrealBuildTool/Log.txt for full exception trace)
4>Total build time: 2939.68 seconds (Parallel executor: 0.00 seconds)
4>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command "..\..\Build\BatchFiles\Build.bat UE4Editor Win64 Development -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command.
4>Done building project "UE4.vcxproj" -- FAILED.
========== Build: 3 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Okay, so I just completely uninstalled both Visual Studio 2017 and deleted my previous UnrealEngine clone, starting over from scratch. I also decided to build everything in my Downloads folder, not my Program Files folder, so as to avoid some sort of authorization/privilege problem. Lastly, I followed the instructions here and here to the letter.

And everything seems to have compiled just fine. I’m getting 4 succeeded, 0 failed. Still not sure what the primary issue was, but it’s fixed either way.