UBT 4.14 crahes on OSX 10.12 compiling project plugin but flags build as successful

I’m working on a plugin for a 2D skeletal animation software which I currently develop as a project plugin (putting plugins into project/Plugins/). You can find the full source code here https://github.com/EsotericSoftware/spine-runtimes/tree/spine-ue4/spine-ue4, it’s a simple UE4 project with said plugins.

Today I’ve updated from 4.13.2 to 4.14. I’ve first converted the .uproject to the new version. Then I regenerated the Xcode project, fired up Xcode and compiled the SpineUE4 target (which compiles the plugins plus game code and fires up the editor, loading the plugins).

However, while compilation via UBT was flagged successful, in reality, the compilation crashes compiling the C/C++ files. It appears the Mono process driving the compilation crashes http://sht.tl/nQp6wD

I’m afraid I could not locate the build log file for this. However, it’s very easy to reproduce the issue:

  1. Clone the project repository https://github.com/EsotericSoftware/spine-runtimes/tree/spine-ue4/spine-ue4
  2. Generate the Xcode project in Finder via selecting the .uproject file in spine-ue4, then selecting Services → Generate Xcode Project
  3. In Xcode, select the SpineUE4 project, and add the flags “-debug -verbose” to the SpineUE4_Build target http://sht.tl/I1ZhEh
  4. Build/Run the SpineUE4 target, switch over to the log view in Xcode, select the executing build and view the log messages containing the build error (but with the build being flagged as successful) http://sht.tl/1SXEsT
  5. In the UE editor, notice that neither the SpinePlugin nor the SpineEditorPlugin have been loaded, due to the failing build.

This is a bit of a blocker, as we currently can’t build our plugins on UE 4.14. The build system is a bit opaque to me, so it’s hard to pinpoint what’s going wrong. Please advise.

Hi badlogic games,

I was able to get access to a Mac today (running OSX 10.12.1) and I tried to reproduce the issue that you described. Unfortunately, in my case the project appears to have built without any problems. I get a result of “Build Succeeded. No issues.” There is also no callstack anywhere in the resulting log that I can find.

The Spine Plugin also appeared to load fine, though it was not enabled (there is a separate issue in 4.14 related to plugins not being enabled as expected). I also tried the same process on Windows and didn’t see any issues there either. Are there any additional details that you might be able to provide to help reproduce this issue? Even seemingly minor details may help.

Hi ,

the only other detail I can provide: I used Xcode clean a couple of times, which required me to verify the UE4 install in the Epic Games Launcher, as all editor and engine executables got deleted by the clean task. I’m not working from UE4 source.

I’m currently trying to start with a fresh install. Will report back if the issue remains.


Well, a fresh install of everything fixed the Mono issue. But as you mentioned, plugins are now not working at all. They are neither compiled, nor loaded in the editor, be it by compiling in Xcode or compiling via the editor. Could you link me to the issue so I can follow its resolution?

The issue with plugins in 4.14 was due to custom plugins in projects upgraded from previous versions of the Engine not being enabled. It was reported in UE-38953. So far, it sounds as though everyone who has encountered this issue was able to resolve it by specifically enabling the plugin.