UATHelper: Packaging (iOS): ERROR: CodeSign Failed

It worked one time and now CodeSign Fails. I have the app on my iPhone so I know it worked once. I tried to package it again after some blueprint changes and now I can’t package again… Help please

Before the questions are asked
A - I am a paid Apple developer.
B - I have my downloaded Provisioning profile & certificate in the project settings and both valid.
C - Everything is set to development.
D - Restarted my computer for the hell of it.
E- Prayed to the lord all mighty but I think he may be at the movies or something…

What do I need to do ?

UATHelper: Packaging (iOS): ERROR: CodeSign Failed
UATHelper: Packaging (iOS): (see /Users/russellmccampbell/Library/Logs/Unreal Engine/LocalBuildLogs/UAT_Log.txt for full exception trace)
UATHelper: Packaging (iOS): AutomationTool exiting with ExitCode=32 (Error_FailedToCodeSign)
UATHelper: Packaging (iOS): RunUAT ERROR: AutomationTool was unable to run successfully.
PackagingResults: Error: Failed to Code Sign

Edit - Got it to package again after deleting the Binaries, Build, Intermediate & Saved folders.

Edit - Seems like I just have to delete the Binaries folder every time… Is this normal?

1 Like

I have this same issue. And the only solution is to delete the Binaries folder (or rename to 00Binaries). This seems like a weird bug.

Same here. Did you find out what was happing? I’m so close to releasing the final build of my game onto the app store and this problem is annoying me.

Help @SupportiveEntity !! :pray:

I did everything that you have done. I have even prayed to the Lord! hahaha But nothing. This really sucks…