UAT exits with exit code 1 on ue4.27.2 source when packaging

I am using unreal engine 4.27.2 built from the source and when i package a game it says AutomationTool exiting with ExitCode=1 (Error_Unknown) i have also tried creating another project and packaging it and this error occurs again.
Please can someone help me because i have no idea what the problem is.

Here is the log:
Log.txt (203.2 KB)

1 Like

same problem ,do you slove it now?

I have fixed it.
In order to fix it open the engine sln file

Then in the solution explorer find AutomationTool and right click and click build wait for it then when it is finished building reopen your project and package the game again.

well,i have builed all the programs including automationtool before ,and still notworking,but still thanks very much

Try building the project within visual studio by opening your projects .sln file and build within that then package it.

This method is very useful, thank you very much.

In this process, I encountered many error messages that access was denied.After entering the corresponding file directory, the attributes of all possible files are cancelled from the “Only Read” state. As setting is completed, go to the vs to build it.