Download

TwinStickPawn blueprint broken in 4.6?

Hi,

I had a project in 4.5.1 that was based on the “Twin Stick Shooter” template. I hadn’t gotten very far with it, so when 4.6 was released, I decided to just update the engine and start over.

All I’ve done so far is:

  1. created the new project from the “Twin Stick Shooter” template
  2. created an emissive material for the projectile (I doubt this is relevant, just wanted to play around with the new emissive lighting in 4.6)
  3. played the game in the editor, no problems
  4. opened up the “TwinStickPawn” blueprint
  5. added a “PrintString” node
  6. hit “compile”

… and I end up with the error shown below. I tried removing the problem node and recreating it and the error persists. I don’t see anything wrong with the “hit” pin. And, oddly, it worked just fine before I opened up the blueprint and recompiled it. It also worked fine in 4.5.1, no matter how much I changed the blueprint.

TwinStickPawn_compile_failed.png

Follow-up…

Now I can’t even open the blueprint. I closed UE and restarted. Now, when I double click the pawn, UE crashes.

That sounds like a corrupted BP. Roll back to a backup in Project Folder/Saved/Backups.

Must have been. I just recreated the whole project, followed the exact same steps, and the error didn’t show up.

Thanks!