Twinmotion Direct link ArchiCAD - add fileversion info


Every time I start ArchiCAD I get a notification about the new update on Twinmotion/ArchiCAD direct link.
It would be very helpful if the linkpage would tell me when it has been published as there is an ongoing issue with the error popping up every time although the file hasn’t been updated since the last installed version.

The downloadable file could also be named after it’s publishing date/ version or similar to differentiate it from previous versions of the same file (easy to do straight away on your website).
Please speed up the process to keep your customers happy

Is Unreal working at all to fix the issues that have surfaced?

  • Unable to install the direct link for ArchiCAD on a MAC
  • The constant nagging about the update being available for the windows version direct link

It would be very helpful to get some kind of information about when to expect the fixes as the MAC version at this time is unusable.



I get the same… I tried to reinstall the Direct Link and I get a message saying “Apple cannot check the file for malicious software… This file needs to be update. Contact the developer.” - I have contacted them at least a week ago and so far NOTHING!!!

I got a message from them that it’s a known issue and they are working on it, but it has been almost a month now, so very slowly :-/
Hope they will get some updates faster in the future so that you will be able to use the program at least - now I have payed for it and not got a working program since may when I reinstalled the Unreal version of it.

A little disapointed, but I understand that the development can sometimes take a while, but in this case an install-file replacement should not be that hard to achieve.

Open the TERMINAL app. Type in the following:

sudo spctl --master-disable

This will add a button in your Security & Privacy settings to install app from ANYWHERE

It’s kind of bogus that Apple makes you jump through hoops to enable this option when before you could simply select it without tweaking via the Terminal.

Anyway, this is what I did and it worked for me. I was able to install it.

The DirectLink is installed and loaded but just don’t work, on archicad 22 mac, so I cant save model in twinmotion…