tvOS "Missing Image Asset"

I’m getting one error when trying to upload a tvOS app that I’m not sure how to resolve.

ERROR ITMS-90471: “Missing Image Asset. Your app is missing the Large App Icon asset AppIconSmall in Payload/”

From every example I see online the sets are named “App Icon - Small” and “App Icon - Large” instead of AppIconSmall and AppIconLarge as I see in the intermediate folder. Could this be a problem? This is not something I can change since this gets generated every time I package. It’s the AppIconLarge set which is the Large App Icon asset that it says is missing.

I’ve also taken the icon images from an example Xcode project to eliminate the possibility of the images not being compatible.


Are you having this issue when actually uploading your app to the store? If so, here is a forum post that I found regarding the issue: [][1]

Good luck!

Yeah I saw that and that’s why I said I took the images from Apple’s example DemoBots Xcode project to eliminate it being a problem with the images.

I get this error after packing with Xcode 7 and Xcode 8. When packaging with Xcode 8 there is an additional error related to the Top Shelf Wide key and image missing which I can actually resolve but I still get the other error.

I’ve run out of options and I’m thinking maybe the folder names need to be “App Icon - Small” and “App Icon - Large” instead of AppIconSmall and AppIconLarge.

Well I did change the folder names in the UnrealBuildTool project and recompiled it and I still get the same error. I’ve tried various icon pictures with no success. I know that one layer has to have no alpha while the others have alphas. It seems to see the smaller set fine but not the larger set.

There a two other posts on this site that had this same error but they didn’t post a resolution. I’m wondering if anyone has successfully uploaded a tvOS app. Can you verify uploading a tvOS app packaged with version 4.14 works? Thanks

I get the same error on:

  • 4.14 once I apply all [my known workarounds for other bugs][1]
  • unreleased 4.15 branch from source

tvOS package for distribution fails to find valid certificate and valid provision [UE-39501] [Workaround] - Platform & Builds - Epic Developer Community Forums


So after you modified the folder names and made sure the layers were set up properly, did your error change? You stated that the smaller images are being seen while the larger ones are not. Do you have the specifications of the images that you’re using, such as size and file type?

Yes I still got the same error and yes I used the correct file type and dimensions. I’ve used the UE4 images that were already there, my own images, and even the images from Apple’s DemoBots example which has 3 layers. The front 2 images for the DemoBots have alphas and the back one does not. So I made my images and the UE4 images the same way.

The larger set which is used for the store has dimensions of 1280x768 and the smaller set which is the home screen has dimensions of 400x240. They are all png files.

I’ve now encountered 3 other posts on this site with this same error. Can you verify that you can upload a tvOS build without getting this error?

We are currently working on this issue and hope to have a resolution soon. Thank you for your patience. I’ll respond back when I have additional information.

Ooh, how exciting! I would love to get my project submitted to the tvOS store.

Hey everyone,

The ITMS-90471 error has been replicated and a bug has been put in: [UE-40545][1]

Unreal Engine Issues and Bug Tracker (UE-40545)

Thanks. There is another error that I was able to work around but that is if packaging with Xcode 8 vs 7 you get an error about Top Shelf Wide key and image missing. Should I enter a bug report for that or do you know if this has been fixed?

The Top Shelf Wide error (ITMS-90513) [is part of my post here][1].

There’s no issue for it yet, as far as I can tell.

Uploading tvOS project: ERROR ITMS-90513 & ITMS-90471 - Platform & Builds - Epic Developer Community Forums