Download

Tutorial: How to proper export a FBX scene from Cinema 4D to U4 with 2 UV channels

Hello everyone,

I finally found a solution to the problem with the missing Lightmap UV channel when exporting fbx from cinema 4D.

Here’s how you do it to get two proper UV channels out:

For every object in your scene, you have to create two UVW Tags. You can simply do that by applying a material to it, select the projection you would like in the material tag (cubic, or spherical, or cylindrical NOT UVW, this will not work)
and then (with the material tag selected) click on "Tags/Generate UVW coordinates.

The second UVW Tag can simply be added by applying a second material to it and just repeat the process.

Now comes the tricky part: In order for U4 to recognize the two channels you need to rename the Tags.
Click on the UVW Tags, and under Basic/Name where it is written “UVW” change this to “1” and int the other tag to “2”.

U4 will use Tag number “2” as Lighting map by default, so make sure it has no overlapping UV’s.
You can do this by going into “BP uv edit” mode, select your UV tag and click on “Show UV mesh” in the UV Mesh menu on top on the right side.
Then select “UV Polygons” on top in the middle and now you should see your UV map in the editor on the right. With CTRL+A you can select all Polygons and now you should be able to play around with the “optimal mapping” settings underneath.
Do this untill you have a proper UV map with no overlapping polygons anymore.

For Tag “1” it is important to have a UV that fits to the shape of the object (because you wonna apply materials to it later in U4), so spherical for Spheres, cubic for cubes etc. In my experience it does not matter for Tag “1” wehter you have ovelapping UVS or not. Sou you don’t neceserely have to go into UV edit for that.

Now for exporting the whole scene into U4:

First, select all your objects and put them in a group. Then export the fbx and import it to U4. Do NOT check “combine meshes” this will put all your objects into one and also overlap all your UV Tags into one, and therefore you will get the “overlapping UVS” error when building the light.

Now, you have all your Meshes in the content browser, how to get them all at once in the editor and keep the relative coordinates?

Well it is a bit buggy. Sometimes you have to try 2/3 times untill it works. Just select them all and drag and drop them in your editor. If it does not work, and your objects are misplace, delete them and play around with your camera view in the editor, sometimes it helps if you are far away from the place where you import your fbx meshes. Honestly I don’t now why it works sometimes and sometimes it will not, you just have to try…:frowning:

If it works and you have all your objects at the right place, I suggest to select them all, check “overriden Light map Res” in the Lighting settings and raise the Number up to at least 200 to get some nice shadows.

click on “build” and if everything went well, you should have no error message about any UV’s anymore.

Hope this could help some of you struggling with this

Greetings

Yama

1 Like

thank you for this. there’s a lot on google about how to do this but nothing worked except your detailed instructions. thanks so much.

You are welcome. Glad I could help…

A little edit:

To get all the meshes at once in the content browser, make sure they are all in one group (in the fbx) and change the editor view to “top” bevor drag and drop them. This works for me now any time, no matter how big or complicated the files are…

Thanks for this Yama, was having some trouble with it.

And just to add, if anybody has any problems with the above,try naming the uv tags inside c4d as 0 and 1 respectively, I had a raft of other issues but I’m sure this fixed something…

Hey Yama, thanks for posting this tutorial! Its a great help.

I’m having issues with importing objects with multiple materials though. Is there a way to do this that you have discovered? I tried renaming my materials 0, 1, 2, etc. but that does not seem to do the trick.

For multiple materials on the same mesh, you have to use material selections in C4D.

  1. in polygon mode, select all polygons that should have a certain material assigned
  2. from the menue select selection>freeze selection to get a polygon selection tag
  3. rename the tag to something suitable (e.g. the name of the material you plan to use)
  4. add the material to the mesh and in it’s material tag enter the name of the selection tag in the selection field.
    Now the material will only show up on the selection.

Repeat this for every material your mesh will be using.

Pro hint:
if you have multiple mesh objects each with their own material and use the “combine objects” command,
the selection tags will be automatically created for the new combined mesh object.

So for example, if you model a window frame and insert a plane for the glass, just assign a frame material to the frame
and a glass material to the glass before combining them to a single object.

The rest depends on your fbx export and UE4 import settings.
You have to check the export option for Textures and Materials in the fbx export dialog.
Also the import settings have to have import materials enabled too.

But i guess you allready knew that.

Hi Kraid,

Thanks for your help. I found the issue with multiple materials only happens when I add a 2nd UV tag. When I do this, the materials import into UE4 just fine, but they aren’t applied to the model and there is only 1 material slot on the model. It seems I can only add a 2nd UV tag OR have multiple materials, not both. Surely, this isn’t actually the case.

Hello,

i tried your method to name 1 and 2 the uvw tags, as a result in ue4 i have 3 channels instead of 2 (0,1,2)

little help?

Just notice there is a tick into the import option “generate lightmap UV” that was the 3rd channel, so do i really need to create my own lightmap uvw tag or just let UE4 create it for me?

Creating your own UV lightmap channel gives you full control over the layout.
By using automatically generated lightmaps you’re stuck with what Unreal computes.
Depending on the complexity and shape of the model, it might work well, or it might turn out not so ideal.

In the end it’s better to have learnt lightmap creation by hand, even if it’s only because you have a better judgement
about the quality of the Unreal generated lightmap UV-Layouts.

Ty so much man for your tips, I got it at the end… Really Thanks

Does anyone of you know how to properly export anything from C4D in an FBX file so that when you import it in Unreal it keeps the textures right? at least the one of the diffuse map? I get always a white material…thanx!

In C4D R16/17 use the fbx version 6.1 2010 and enable the checkboxes for Textures and Materials.
On import in UE4 you’ll also need to check the checkboxes for import materials/textures.

Alternatively try Cactus Dans fbx exporter.

Hi dsenter,

I had similar issue with Substance Painter. It worked only with ether 2nd UV OR multiple materials via selection tag. When both were present Substance crashed.
I found fix by changing tag order. First selection, then materials, UV and phong. Something like this:
SelectTag1|SelectTag2|Mat0|Mat1|Mat2|UV1|UV2|phong

Hi dsenter,

I had similar issue with Substance Painter. It worked only with ether 2nd UV OR multiple materials via selection tag. When both were present Substance crashed.
To fix this I changed the tag order. First selection, then materials, UV and phong. Something like this, it works for Substance:

SelectTag1|SelectTag2|Mat0|Mat1|Mat2|UV1|UV2|phong