Download

[Tutorial] Fix for the Visual Studio Update 3 without Source Control!

Only Tested with 4.12 Launcher Version

Go to :


C:\Program Files (x86)\Epic Games\4.12\Engine\Source\Runtime\Core\Public\Windows


and Search for


WindowsPlatformCompilerSetup.h

Chance the Properties and Remove the Read-only.

Open the File with a Text Editor Search for Line 29 and 30 and replace those Line with this:


#pragma warning (error: 4500 4501 4502 4503 4504 4505 4506 4507 4508 4509      4511 4512 4513 4514 4515 4516 4517 4518 4519 4520 4521 4522 4523 4524 4525 4526 4527 4528 4529 4530 4531 4532 4533 4534 4535 4536 4537 4538 4539 4540 4541 4542 4543 4544 4545 4546                4550 4551 4552 4553 4554      4556 4557 4558 4559 4560 4561 4562 4563 4564 4565 4566 4567 4568 4569 4570      4572 4573      4575 4576 4577 4578 4579 4580 4581 4582 4583 4584 4585 4586 4587 4588 4589 4590 4591      4593 4594 4595 4596 4597 4598     )
#pragma warning (error: 4600 4601 4602 4603 4604      4606 4607      4609 4610 4611 4612 4613 4614 4615 4616 4617 4618      4620 4621 4622 4623 4624 4625 4626 4627 4628 4629 4630 4631 4632 4633 4634 4635 4636 4637 4638 4639 4640 4641 4642 4643 4644 4645 4646 4647 4648 4649 4650      4652 4653 4654 4655 4656 4657 4658 4659 4660 4661 4662 4663 4664 4665 4666 4667 4668 4669 4670 4671 4672 4673 4674 4675 4676 4677 4678 4679 4680 4681 4682 4683 4684 4685 4686 4687 4688 4689 4690 4691      4693 4694 4695 4696 4697 4698 4699)

Than Go to the Line 119 and paste this after the Line 119


#pragma warning(disable : 4599) // VS2015 update 3 : When using PCH files, mismatched -I include directories to the compiler between -Yc and -Yu compilations will now produce a new warning.
#pragma warning(disable : 4605) // VS2015 update 3 : Seems related to 4599.

Now Chance the Properties to Read-only and it should work again.

Here The Source Chance on Github
You Can only see the Link when you have your Github Acc Linked with your Unreal Acc!

Sorry I’m confused by the title, when you say without Source control do you mean this will work without downloading the Source from Git?

Works great with binaries on 4.12, thanks so much! I’m going to try applying it to 4.11

I can confirm these exact instructions also work for 4.11.2, thanks again Rigjaw!

any ETA on a proper fix for this ?

You are my Hero, This worked beautifully. Thanks a Million!

Thanks very much for posting this, Rigjaw!

I can confirm it works on the 4.12.4 version. Thanks Rigjaw! but if I may ask, what does this do exactly?

this didn’t fix ****. 1fcb71dad84e38eaa1a33f5f872c6952797f2de4.png

Read the Error Message?

When Visual Studio is Installed you must Install C++ in Visual Studio to it doestn install it in the default Settings.

When you Uninstall Visual Studio you can choose in the Uninstall Window “Modify” and under the Programming Languages Section Activate Visual C++ and then press Update.

You can also download Visual Studio 2015 Update 2 here:
https://gist.github.com/CHEF-KOCH/8078b39e1aad71ef6c317a3c0edb6ec9

I hope this help you :slight_smile:

omg thank you so much this worked, I kept searching the internet with no avail until I stumbled upon this particular post.

4.12.5 fixes this issue, apparently!

Thanks you! It worked for me!! :smiley:

Thx for the solution,It worked~