Download

Turning off physics simulation on character blueprint

Hey guys,

How can I turn off the physics simulation off on a character blueprint?

I have my character blueprint with the ability to run and jump, but I also want them to be able to grab onto objects that are in the air. To do this I have used the attach actor to actor, which snaps the location but doesn’t seem to actually ‘attach’ the two objects together. My plan is to disable the physics simulation on the character whilst it is ‘grabbing’, then turn it back on when it lets go. Is this the best way to do it?

you can use something like physics interaction. When you access the character nods, you will find loads of useful stuff

695b08208191aaf9e0d16faaace5bbfb22a5a908.png

Thanks for the post!

You made me realise I was referencing something else. I was using ‘Get Movement Component’ instead of ‘Get Character Movement’ - and you’re right there are a load more options in there.

In the end I went with the following:
blueprint.png

glad it works :slight_smile: