Turn a pawn but not move it

I followed these tutorials to create the turnaround Getting the Animation Results You Want Part 5 | Live Training | Unreal Engine Livestream - YouTube and it worked.

Now the problem is this: the pawn’s movement happens during the turn animation. For the duration of the turn animation the pawn should stand still, changing only the turn. Can you tell me how to block the pawn’s movement in space for a certain time (parameter) without blocking its turn?

1 Like

Just disconnect these


You can do it with a bool, ‘turning’, for example.

1 Like

I had the same problem with jump end animation. While character was landing on his feet you could move him in any direction, so i needed to disable movement input during this animation, leaving only option to use mouse (lookup, turnaround).

How to do it (in your case - with turn animation)?


  1. Create notify event in turn animation (in my case it is JumpEnd animation).
  2. In Anim Blueprint in event graph pick up this event - cast it to Character Blueprint - and set logic (see pictures).

N.B. “Set Ignore Move Input” - disables only movement input. If you want to disable also look up/turn around - use “Disable Input” / “Enable Input” with the same Delay function.

  1. In Character Blueprint event graph call this anim notify event.

Good luck! :wink:

P.S. It turns out that you don’t need to call Anim Notify Event in Character Blueprint.
Just Animation Blueprint - that’s enough)


Not Fixed: