Download

Trying to open UT4 sample map in editor

This is the error:

LogLinux:Error: appError called: Assertion failed: Assertion failed: WorldSettings != NULL [File:/work/unreal/UnrealEngine/Engine/Source/Runtime/Engine/Private/Level.cpp] [Line: 1559]
/Game/Maps/PostAndLightingExample.PostAndLightingExample:PersistentLevel

Editor crashes to desktop as a result.

Could you probably post the editor log -> project - saved - logs :slight_smile: Are you abel to open another UT map? You use the UT project or do you open it from another one (e.g when you have migrated it into your own project)?

I can’t open any of the UT maps. All produce the same error. I tried to change the default WorldSettings in the project. That didn’t help. I also tried adding this line to the defaultengine.ini file:

+ActiveClassRedirects=(OldClassName=“AUTWorldSettings”,NewClassName=“AWFWorldSettings”)

Stupid question, but are you actually using the UT version of the editor?

aslo remember that the maps use custom UT content and that UT is now using the 4.6 preview build

Not using the UT version of the editor. Using the 4.5 master. I know that some actors are not there. But I just wanted to see what the maps looked like. Oddly enough, I can load the maps and play them if I start them outside the editor.