Download

Trying to make Titanoboa's inventory to work (need some help)

So I’ve been messing with the dev kit a little bit. My objective is to replace the Titanoboa with a one with working inventory. I made a new DinoTamedInventoryComponent_Boa blueprint (copied Dilos and edited it), then linked that file to a copied BoaFrill_Character_BP. The problem is that I’m not sure how do I make the PrimalGameData to read the change and use the modded Boa blueprint along with the new inventory file.

I also tried to make a separate Titanoboa too with the JasonFJ guide, but for some reason I fail to get it to spawn in the game. Tried to spawn with the console and changed all cave spawns to the new Boa with no luck.

All I’m trying to do (for now) is to get the Boa’s inventory to work. I would really appreciate the help.

Did you remap the NPC (Old Titanboa to new one) under primalgamedata_bp_yourcustomone? If not that is why.

I tried. I remapped the file “BoaFrill_Character_BP” to the new one. Or do I need to remap something else?

Wow, it actually works now. At least in the devkit when I try it on the test map. Tried to cook & upload it, but it doesn’t work in-game.

EDIT 2: Finally it works in-game! I’m not if the cooking/uploading process is buggy or the downloading from the workshop. At least now it works, I’m gonna try to get it on my server and then I might release the mod.

Probably the issue is with downloading it from the workshop. Myself and a few others seemed to have experienced similar issues recently.

use the adk launcher and run mod before upload to check it works