Trying to limit spawning through variables [Solved]

So, first off, I suck at blueprints/programming. If I could afford it I would just hire someone with the know-how.
So I purchased the tame and mount blueprints from the marketplace (great buy) and now I’m trying to prevent multiple mount spawns. So in the despawn mount function I had it set the mount to “OutOfPlay”. Now I want the summon mount to check and see if it has that variable set, before allowing the actor to spawn. So this part is in The player blueprints but I want it to check if the Summon has the variable set and it wont let me. Is there something simple I’m doing wrong, or is it the whole shabang?

I have posted a question to them on their asset page, but I haven’t heard anything back yet, so I’m keeping my options open :>

I think you should take this up with the seller, as they are more likely to be able to help you out with it.

Got it!! thanks to this tutorial: - YouTube
I don’t fully understand classes but you just see if there are less than one of that summons class. Booyah