Trying to launch ./UnrealEditor from Ubuntu 22.04.4

Hello Everyone, I am a newbie here. I am trying to launch Unreal Engine 5.4.2 editor from the Ubuntu terminal (using WSL) for a project. I first tried to clone Unreal Engine Repo with Git on the Ubuntu Terminal with this HTTPS link “https://github.com/EpicGames/UnrealEngine.git” and then proceed to run Setup.sh from the root directory, followed by GenerateProjectFiles.sh, followed by ‘make’ commands according to the documentation on Unreal Engine site “Building Unreal Engine from Source | Unreal Engine 5.4 Documentation | Epic Developer Community”. All was going well until I tried to launch ./UnrealEditor from my Linux directory (\UE5.4.2\UnrealEngine\Engine\Binaries\Linux). Initially an error popped up saying that it can’t launch from ‘root’. So I ‘su’-ed into my user account and tried giving the user “same permissions” as root user with visudo command, editing the file /etc/sudoers.temp. E.g tom ALL=(ALL:ALL)ALL.

i got so desperate i tried asking Mr.GPT and installed “sudo apt install build-essential clang-10 python3 mono-mcs xdg-utils libvulkan1 vulkan-utils libssl-dev libudev-dev libxrandr-dev libgtk-3-dev libopenal-dev libfreetype6-dev libvorbis-dev libogg-dev libpng-dev libjpeg-dev libxinerama-dev libxcursor-dev libxcomposite-dev libxdamage-dev libxi-dev libxrender-dev libxrandr-dev libfontconfig1-dev libxcursor-dev libpulse-dev libasound2-dev libcurl4-gnutls-dev libbz2-dev libgmp-dev libglib2.0-dev” (I clang-15 installed instead) and also “sudo add-apt-repository ppa:graphics-drivers/ppa” just trying anything at this point. i updated my NVIDIA drivers to the latest versions.

Now i tried launching ./UnrealEditor again from my Binaries directory again and the Unreal Logo loading picture did pop out:


but vanished after a second or two. Now the error is saying that my Vulkan Driver cannot be found.

What do I do now :confused: any advice would be much appreciated! Thank you

Chatgpt is not the place to ask, honetly your best bet would be ubuntu forums. But the warning says it can’t find a vulkan driver, so, is your vulkan driver installed? If it’s not, maybe start by fixing that, yeah?

Also you are absolutely trashing your security with that

editing the file /etc/sudoers.temp. E.g tom ALL=(ALL:ALL)ALL

I would strongly recommend you undo that. What you should do instead is change the permissions for the engine folder, something like

chmod -R a+rwX /opt/unreal-engine/Engine

1 Like

Is there any (good) reason you are trying to do this in WSL?

Seems counter-intuitive, just run the Windows version.

Oh he’s using WSL… yeah you’re right about that. If he wants to use the linux version of the engine he would be far better off dualbooting.

No wonder it couldn’t find the vulkan drivers, I don’t think WSL has much in the way of graphical capabilities.

https://www.reddit.com/r/vulkan/comments/1b4ib83/is_there_any_way_around_using_vulkan_on_wsl2/

seems like wsl only supports vulkan via software rendering, which would be lavapipe (I believe this package might be called something like vulkan-swrast though i’m not on ubuntu so can’t be sure)

Running unreal through it would be hopeless.

1 Like

thank you for the follow up! i’ve been trying to get WSL to find vulkan, or even a video device (couldn’t initialize SDL) for the past few days but to no avail as well.

But we decided to not pursue the matter anymore and just work with Windows. The project i’m working on tinkers with pytorch in Unreal Engine (but really slow) so we wanted to see if it would be faster on Linux (somehow). But thanks for all the answers and help!

If you want to see if it’s faster on linux, WSL is not the way to go, you’d need to use a native linux installation for any real comparison.

1 Like

So Unreal Engine uses Vulkan and NVidia drivers normally. On your Linux system you should be able to update your vulkan drivers manually through the terminal.

Though I see in your commands list there vulkan1 should’ve been applied. Was there another update from the Linux Application Updater for any of the drivers you installed?

It should’ve:

  • sudo apt install libvulkan1
  • vulkaninfo could be used to check version information

Although a lot of this information is on the Linux Config Org Page:

I wish however Epic would update this information for Linux in connection to their Steam Dev Instructions:

Especially Considering this page is blank on their updated documentation layout:

as it was meant to continue here:

Though I get that not everyone is on Linux, it would help to explain their cross compile options available.

Worst Case Scenario you can check Unreal Containers webpage:

As there used to be images and setup info if you were using Docker. Which also has WSL

1 Like