Download

Trying to install 5-0EA source, unable to to generate project files

I have UE4 source build 4.26, and since I couldn’t get UE5 EA source to fork (kept telling me I already had a fork, which was just the UE4 version) I downloaded the zip of the source instead from github. When I tried to install it, I got this. I haven’t installed like this before but I did follow the ReadMe. I have Visual Studio 2019. Also have the binary of UE5.

Steps followed:

I’m trying to learn how to package a simple dedicated server, and need to migrate my project to a source build in order to do so.

Would appreciate some help. I’m not terribly savvy with this stuff.

You should try UE5 main or UE4, example 4.26 (That worked on me with following commands).

I use linux.

Try this:

  • Clone it (or download zip)
  • Get into cloned/extracted folder
  • Run: ./Setup.sh – This command is about 3 - 4 hours
  • Run: ./GenerateProjectFiles.sh – This command is about 15 - 60 mins
  • Run: make – This command is about 2 - 3 hours

Start it from UnrealEngine/Engine/Binaries/Linux/UnrealEditor – For UE5
Start it from UnrealEngine/Engine/Binaries/Linux/UE4Editor – For UE4