Trying to dynamically control size of the particles via Blueprint at runtime

I have also asked this question on the rendering forums link. I have created a simple particle system from the default particle system: They are identical except one has type data as GPU sprites. Two actors with each with a particle systems is created, I assign the two different template of particle system to it. The Particle settings are also attached. The GPU particles are not updating based on the vector parameter size distribution, any ideas of why its missing it ? Or is there a different way we should be calling a dynamic update on GPU particles ? Please advise.

I have tried to refer to similar question asked in Answer hub :
However the information doesn’t seem to have helped me resolved this issue. I have tried a different combinations for the max and const values as discussed in the answer.

You cant really update gpu particles after they are fired, which is also why dynamic modules arent available.

So it must be recreated, is that the only solution in your judgement ?

yes, unless you need thousands of particles you might want to use cpu particles instead.