Trying to build 4.10 w/ VS, keep getting 4.11

Hey guys, thanks in advance for your help. I’m a bit new to the engine. I’m trying to build version 4.10 specifically to try out a plugin, but somehow I keep getting 4.11 instead of 4.10

Here is a list of my steps:

  1. Open console. git clone https://github.com/EpicGames/UnrealEngine After I got 4.11 the first time, I tried replacing this command with git clone https://github.com/EpicGames/UnrealEngine --branch release --single-branch and got the same results.
  2. Run Setup.bat. Completes normally.
  3. GenerateProjectFiles.bat. Completes normally.
  4. Launch Visual Studio 2015. Open UE4.sln.
  5. Build > Build Solution. Wait. Build is successful.
  6. Debug > Start Debugging.
  7. The splash screen reads “Unreal Editor 4.11.0”

I’m running Windows 10 64 bit.

What should I do differently to get 4.10 and not 4.11?

Almost there! You can use the same command as before to specify 4.10 instead of release, i.e:

git clone https://github.com/EpicGames/UnrealEngine --branch 4.10 --single-branch

Hey blackij-

The 4.11 preview was mistakenly merged into the release branch which is why it gave you 4.11 instead of 4.10. You can use the 4.10 branch as MilkyEngineer mentioned or you can use the 4.10.1-release tag specifically. We are looking into the preview being merged to Release internally.

Cheers

Doug Wilson

ah, that makes sense. thanks for the info.

this worked. thank you.