Download

True No Collision

I have got a mod that is taking off quite fast and am in the process of adding all structures with no collision. I was hoping that the additions to my mod would work with the likes of Structures Plus so I wouldn’t have to add all of the structures myself, but it causes problems. So here we are.

Screenshot 2016-09-06 22.09.36.png

Simply de-selecting ‘Use Placement Collision Check’, you would have thought anyway, does not completely alleviate the collision while placing the structures. You still have, what appears to be, the pivot point, or center of the mesh, where it sees it as colliding, so you cannot place it. I have also tried disabling collision completely through the ‘Collision Presets’, this actually does nothing. I have tried deleting the collision from the mesh, this also has the same results. I have also tried using script to change the ‘Collision Preset’ once the structure has been selected, but this I can only get to trigger when the item has already been placed, so I cannot test it to see if it would work. The ‘Placement Encroachment Check Offset’, ‘Box Extent’ and ‘Placement Trace Scale’ all seem to be deactivated with the ‘Use Placement Collision Check’ de-selected so this cannot be it. I have gone through every setting and if it looks like it could be it, I have tested and still got no results.

The worst part is, and the is truly chewing me up, I know it can be done as it already has been done. I just can’t seem to find how. I have scoured this forum and tried google for the last few days with no decent results. I have also tried contacting the creator of Structures Plus, I might as well be a brick, lol!

I have so much planned for this mod in the way of structures and building that this is really holding me back. I know I could carry on the way it is now with not being able to place things through floors and cliffs and such, but then I’d be settling and really don’t want to do that. In only 11 Days I already have 6,888 subscribers with 323 positive ratings. I don’t want to stop or settle, I want the best.

Please help me if you know how I can fix this. All credit will be given. :smiley:

I assume you tried to contact me by only friending me on Steam because I’m pretty consistently in the modding Discord chat and I respond to most comments/posts on my mods(note: I don’t accept friend requests on Steam anymore).

I don’t consider the no collision stuff secret and have shared it many times in the past, in fact the reason for my making Structures Plus was because there wasn’t any mods that were implementing the code even after I gave it to them and my Platforms Plus mod needed working no collision so you could place walls that were partially obstructed by trees.

That said, you need to override the BPIsAllowedToBuild function:

Here is a list of reasons that prevent placement(there might be more since I last made this list a few months ago):

0 - No ground or snap point
-1 - cant place on floor
-2 - obstructed
-3 - no snap point
-4 - requires placement on ground
-5 - requires nearby foundation support
-6 - requires connection in water
-7 - requires sunlight location
-8 - out of placement range
-9 - too high above ground
-10 - too close to enemy
-11 - too many structures nearby
-12 - cant place underwater
-13 - cant place structure here
-14 - cant place structure here until wreckage dissipates
-15 - too many custom paintable structures nearby
-16 - cant place too close to structure of similar type
-17 - can only build on suitable allied platforms
-18 - there are already too many structures on this platform
-19 - this structure is too high above the platform
-20 - the elevator platform requires placement on a free elevator track
-21 - this structure can not be placed on a platform
-22 - there are too many creatures with platform structures on this ark
-23 - this structure is too far away from the platform
-24 - this structure is out of bounds
-25 - you are not authorized to replace this structure
-26 - your tribe group rank is not permitted to build within range of your tribes foundations

Thank you soo much! You are a god!

I don’t suppose you can tell me how to implement the key press commands? Like you have done with the fence posts. They don’t seem to do anything when I use them.

Please!

First, thank you for this helpfull Post. But i allways have some issues placing my Walls like on this pic i posted on the end
It says = “Structure cant be placed here”
Any help how to get rid of this ? I already set the Graph like Orionsun shows us :frowning:

e648e306f81b9cc27d8dcfc37f2e497d0ae2e886.jpeg

Well, ok i found out something what maby works. In DevKit i didt get any “Cant Place…” msg. i will try on server and sp and give you a feedback.

No more Structure is “obstructed” or “cant place here” msgs anymore. So it works :smiley:

i`m a happy minion now XD