Download

True Fullscreen?

I’ve been fiddling around with the config files, as described elsewhere, but I can’t seem to get it to run in true fullscreen. I’m using 4.7.5, and I’ve currently got the settings as:


[/Script/Engine.GameUserSettings]
bUseVSync=False
//ResolutionSizeX=1920
//ResolutionSizeY=1080
//LastUserConfirmedResolutionSizeX=1920
//LastUserConfirmedResolutionSizeY=1080
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=True
FullscreenMode=0
LastConfirmedFullscreenMode=0
Version=5

I’ve also tried with FullscreenMode as 1 and 2, and with bUseDesktopResolutionForFullscreen as off, but neither work - I get a fullscreen-adjusted window, which consequently won’t lock the cursor or activate 3D Vision. It must be possible, I’ve seen other Unreal 4 games use true fullscreen, so what gives? :confused:

For reference, I’ve also tried the C++ approach of using:


UGameUserSettings* Settings = GEngine->GetGameUserSettings();
Settings->SetScreenResolution(FIntPoint(GetSystemMetrics(SM_CXSCREEN), GetSystemMetrics(SM_CYSCREEN)));
Settings->SetFullscreenMode(EWindowMode::Fullscreen);
Settings->SetVSyncEnabled(false);
Settings->ApplySettings(true);

which also doesn’t fully work.

There is a console command ‘FULLSCREEN’ & ‘WINDOWED’ if you want to use it. Also ‘SETRES 1920x1080’

Both typing those into the console and sending it to the application by means of program argument doesn’t seem to do anything? :\

As standalone game? I just tried it and works here, sorry I’m not sure why.

I just hit Alt+Enter :slight_smile:

Universal Full screen command since 19somethingsomething (I really hate when games don’t have this)

Garner is straight up right but if you are trying to get Fullscreen in the editor while previewing, hit ‘F11’ I believe it is. (it’s in editor keybinds)

If you are trying to get the Editor to do this automatically you have to set it in a config file and save it in a certain place to get it to work. (search answer hub for this solution)

If you want it to run Fullscreen in ‘Play’->‘StandAlone Game’ or in a finished or packaged game, you can do this:

(normally would use a flip/flop instead of a branch but it works more consistently this way)
(this is an UMG Menu example, the event is a button that is clicked from UMG)
(you can do this almost anywhere by either setting an action event to a key in project settings or just right click & hit the key you want for a key event node in the BP)
(console command node works for screen resolutions as well just have to be careful with it, unless you are polling the users settings etc. in an actual game & I can’t remember exactly where it is but you can do the same w/ screen resolution just by adding a w or and f but vague on that exactly)(search for this info it’s out there)

(still hoping they expose & setup a cleaner easier way to handle user settings like this but for now this is it, as far as I know)

Bizarrely, this bug no longer appears to be the case as of the latest update. Huh. Clearly Azathoth is playing a prank on me or something. Thanks anyways!

Hey there I am having the same problem using the ini file technique, Ayretek this looks interesting but as im fairly new to the blue prints not sure what each node your using so was wondering if you could either tell me in writing or create a quick video on how to create this as only need it for a first person experience

cheers

all right,thank