Download

Troubles importing a model from a 3D Modeling software

So, I’ve been modeling inside of Maxon Cinema 4D. When I export the model (that is all grouped together in C4D) as a flx and import it into unreal engine 4, it inserts every part of the model individually. Instead of the one model it imports all the pieces that make up the model individually. Does anyone have any experience with this and might be able to help me? I can’t seem to find a solution anywhere.

Try the combine meshes checkbox in the UE4 Import Dialog.

Also by grouping objects together you mean putting them inside a Null-Object in C4D?

That way they will be still seen as individual meshes on import and end up as a own entity (unless combine meshes is checked).

A much cleaner way of doing this is to use the merge objects command, which will create a single mesh from the selected meshes.

Most of the time a C4D to UE4 export fails it’s because of a wrong model setup including Tag order or simply because of wrong export/import settings.

IMO the best working one is still fbx 2010 v6.10 (ofc. depending on the C4D Version you’re using).
Make sure all the right checkboxes are checked and the mesh is prepeared for export.

E.g. as soon as you use two UV channels (name the UVW Tags differently in C4D) you have to make sure all your material Tags are on the very left of the Tag stack, otherwise there will be an error with Unassigned Materials on Import.

Thank you for replying. After I checked combine meshes they’re where all put together correctly. However whenever I imported them they are mostly transparent. Here is a screenshot of what I mean so that you or someone else can understand better:

I’m new to a lot of unreal engine and I’m not really sure what export/import settings I should be using. I’m not texturing inside of Cinema 4D, I plan to apply textures and meshes in UE4. The models I’ve been importing are just test models with a couple simple primitive objects placed inside a null object. But later, I plan to import complicated models and I want to know that I’ll be able to import them. (That’s why i’m testing the import phase now.)

Judging from your Screenshot, i’d say it’s the backface culling.

If you enable backface culling in your 3D Viewport in C4D (top bar of the 3D Viewport: Options>backface culling, or press N+P at the same time) it should look exactly the same.

Backface culling is used mostly in realtime graphics to enhance performance.
Every polygon where the face normal is facing away from the camera, is not seen by the renderer.

facenormals.jpg
The cube on the right has face normals facing outwards while the cube on the left has them reversed. (backface culling activated)

It’s possible to deactivate the backface culling in UE4 too, but i’d strongly advise against it, since it can only be applied on a per material basis.
So everything that uses this Material will always be displayed with it’s full polycount even if just one polygon is visible.

It can make sense to use it on 2D shapes such as sprite cards or tree leafs though, since you usually want these to be seen from both sides
and have a seperate material because of the alpha anyway.

As for the texturing, make sure to get familiar with UV mapping and Material selections.

It’s just to much stuff to explain it here and now.

Just one more thing to get started: there’s a difference between a texture and a material.

Textures or texturemaps a 2D image files usually used in sizes of 2[SUP]n[/SUP] (2,4,8,16,32,64,128,256,512,1024,2048,4096…) for length and width.
Materials are more of a description of how a surface behaves under certain conditions.
These can be determined by a value, a pixel image or even complex setups of instructions.