Download

Trouble with simple blueprint function on primitive

I put a sphere and cube in a scene and as part of my learning process through the documentation, I am trying a simple move. I am attaching the image here. The “Toggle Visibility” function works, but “Set Physics Linear Velocity” or “Add Force” and many other movement functions won’t do anything. I’ve gone through the mesh settings and made sure physics works and that it is moveable and also tried all the axis, but I am still not getting results. Also I know the communication is working because I can see the links firing up.Is there something obvious I am missing?

The velocity one should be working… are you sure EditorCube11 has physics enabled?

As for the add force, you simply don’t add enough force (remember add force will add velocity based on the mesh’s actual mass) from what I have tried you will need to add over 900000 to get the MaterialSphere moving on the Z axis.
Also keep in mind that add force is not really meant to be an “instant force” but rather a force to be used over a period of time (usually in the tick event).

Tk-Master, now it seems to work. I had to change the collision presets to “PhysicsActor”. I don’t really understand the logic, and when to put which preset, but I guess I will have to use trial and error.