Download

trouble with Landscape retopology

Hi ,

Microsoft OneDrive - Access files anywhere. Create docs with free Office Online. < what is causing this artifacting, and how do I fix it ? :wink:

I redid topo making It much cleaner, set uv map res in editor to 128 and got mesh down to 83k.

I’ve tried the ‘seperating’ mesh into more pieces but that just makes ugly obvious lines , and going down to anything much lower than 83k is going to look quite ugly so that’s a non starter.

I have zero overlapping UV’s so its not that either but lately I have gotten ’ Degenerate Tangent Bases ’ error, but using mesh editor option of recompute tangents , at least on complection of lightmaps generate no errors, so it seems unlikely its a lightmap issue right ?

Microsoft OneDrive - Access files anywhere. Create docs with free Office Online. < this occurs also, if this helps in diagnosing what’s going on :wink:

Oh btw and not sure if it is relevant, but viewing mesh in static mesh editor, and these bad images are not present at all, looks perfect.

I found elsewhere on answers.unreal, it could be stray vertex possibly*&/or ‘smoothing groups’, but the fbx I exported from blender, has ‘smoothing’ set to faces which I presume is whats needed, or do I need to set this issue in blender settings somewhere ? Just thinking to think of all possible issues.

ty
nl

  1. I dont know exactly what the problem is :smiley: -> but does it look right when you use dynamic lightning? (post a picture of how it should look like)
  2. to get rid of those shadows you will have to increase the lightmap resolution of your landscape

I bing’d, found a 'lightmapping panel in usity or what it looks like anyway, but how do I get to it ?

I have no idea how to enable dynamc lighting, or is that PRO only ? ;(

OH btw, the non live view of my scene looks the same as live play mode.

THis is picture of how it looks non live as you requested:

https://onedrive.live.com/redir?resid=79A04534F6B84EF5!25016&authkey=!ALGwuxj9YmsLA9c&v=3&ithint=photo%2Cjpg

cheers and thx for any help you can be on this issue.

nl

  1. to change the lightmap resolution you will have to click onto the landscape - in the details panel you can change it (e.g to 2 or 3)
  2. Dynamic lightning -> Just set your lights to “moveable” (in the details panel)

Dont forget the picture of the mesh in your 3d program -> so that I know what exactly you mean :smiley:

sorry ya it just took a few as I was a little busy sorry bout that heh, but its there now ;))

I’ll check settings as you described while you look at it.

>>>>>>>>
image is embed now for you to look at and you can clearly see I have smooth turned on, and there is no ugly artifacting and topo is very clean as I’ve worked very hard to do so for obvious reasons :wink:

cheers
nl

OK, I set lightmap res. to 3, made all lights whether large directional or pinpoint lights to all moveable,and things are mUCH better.

I’ll check and make sure how things look in all places where it was an issue and update this post, sorry for this non live conversation I realize its very non optimal :wink:

EDIT EDIT: Ok lighting is MUCH better, but still have some artifacting,but nowhere near what it was before :wink:

I’m using build ‘preview’ for lighting, can that cause these issues as well? :wink:

cheers
nl