Trouble with importing FBX from DAZ3D to UnrealEngine

Hello.
I’ve placed in DAZ3D 4.7 Genesis2 Female object and exported it to the FBX (2012, 2013, 2014). After that I am trying to import it to the Unreal Engine 4.7. After import I have deformed object in UE 4.7:

How to fix this bug?

Care to show your export settings?

Are you importing as a Skeletal Mesh or a Static Mesh?

I have had similar issues with Daz. What I Do is export them, import them into 3dsMax, and resave them. 3dsMax will find issues and correct them on import. Of course you need the program…
Also when you export from Daz and if you can, exclude any cameras, props, animations that you do not need.

Hello.
My export setting are:


OK, I’ll try to export through 3ds max…

This is a known bug in 4.7:

Maybe this is fixed in 4.8P1, but I didn’t have time to try it.

Workaround: import and re-export in Maya (LT) or 3dsMax

I’ve try to check this in DAZ3D 4.8 - it still has bug…
After re-exporting through 3DS Max mesh works good, but textures of eyes is not showing…

might not be the same for daz, but when you export from makehuman, it has a separate material for the eyes, you need to set the blend mode to transparent and connect the alpha of the tex sample to opacity for the eyes to work properly.

I can Import from DAZ!? this just got way cooler… lol

Not sure 100% what the problem is but it “could” be a rounding error when Daz exports it’s weight table. (Daz uses a different skin solution that has to be converted to every day skinning solution.)

Works this way. If a Vertex is exported weighted to a single link with a value of .0000000000001 then its weight is still consider 100%. If importing into an application like UE4 that can only except data to the forth place then its round out as being zero as to weigh so the link is no longer weighted to anything and will snap to it’s bind pose position.

Importing into and out of an app like 3ds Max works because by default weight all vertices can be turned on which will set .0000000000001, which is 100% to 1.0 which is still 100%.

What might work (as I really have no need to try it) is to use the free Autodesk FBX converter and import/export as a wash and rinse and fingers crossed will fix the weigh table.

I have the same problems with the eyes texture. How i do what do you say?

When you mean this:

then you have to do it like that:

I just saw this post and it seems like many people have same issue with Daz FBX import. I gave the FBX converter a try but still no luck even with latest UE4.10.0, I kept getting the sharp edge sticking out of the mesh problem.

Strange enough though, when I view the file using FBX Viewer (In the same converter application) the character looks normal without anything sticking out. I’m using Genesis 2 basic male figure.

f0fad0164532680c455475915243d33e1972794e.png

I also did tried the UE4.6.1 suggestion and it actually works fine without anything sticking out (just takes a long time to load). UE4.9 also didn’t work.
So my question is : once I have the skeletal mesh imported into UE4.6, how do I upgrade the mesh so I can load into a more recent version?

Another question is how do I import the animation from Daz? I tried to find tutorial on this but not successful. In DAZ I used a simple animate2 walk cycle and baked to keyframes, then I exported the animation to FBX. However when I tried to load the animation into UE4.6 it would always complain that no animation take is found.

How to use DAZ3d Studio Genesis 3 Characters with auto-rigger from mixamo.com
How to use DAZ3d Studio Genesis 3 Characters with auto-rigger from mixamo.com - Community Content, Tools and Tutorials - Unreal Engine Forums

Give Makehuman a try. It is working great now and it is free.

Ok after some trials and errors I found a way that the mesh and animation can be exported from DAZ3D to UE4 using Blender. It took a lot of tries but I think I finally got it working with UE4.10. I know people have got it to work with MAX3D, but it is just not an option for me due to the huge price tag. I liked DAZ3D over Makehuman since DAZ3D has more clothing selections, with Makehuman you probably have to spend a lot of time and effort to make it. The workflow I used is :

DAZ3D export to Collada (DAE) => Blender export to FBX(Binary) => import UE4

For the Blender export, make sure it has to be Binary otherwise UE4 complains that no valid animation take is found.

I’m seeing some warnings about smoothing group and “Imported bone transform is different from original…”, but other than that it appears to be working.

Hi wsu, that sounds very promising, but I have a question. When you imported into Unreal, was your character UV mapped and if so, were there any major errors with it?