Download

Trouble re-establishing ground between 4.12.2 and Visual Studio Community 2015

I had previously compiled the UE4 source code in Visual Studio 2013 to implement FFakeStereoRenderingDevice, took notes on my steps, and had successfully packaged a build in UE4 4.9.3. I didn’t realize at the time that my version of VS was a trial version, and since my build functioned well, there was no issue there anyway. Months later I then returned to the project to make some edits to a level, only to run into problems packaging. The issue was traced to my lapsed trial version, wasn’t aware that packaging required compiling, thus reaching out to a lapsed version of VS. I then uninstalled VS 2013 and installed VS Community 2015, finally got it to launch. I also upgraded UE4 to 4.12.2, having read that one of the upgrades was to make it compatible with and requiring Visual Studio 2015.

And though I took good notes to retrace my steps how to generate the SNL file that links the engine in the source code to open in VS, I’m now really confused why I’m running into walls. After upgrading UE4 to 4.12.2 I then downloaded the source code, opened the UnrealEngine-Release folder, ran Setup.bat, which reached 100% with the upgrade. My notes directed me to RMB click in an open space in the window of the UnrealEngine-Release folder, select Command Prompt, but this go round that option isn’t available. I noticed GenerateProjectFiles.bat was in the directory, so I just opened Console, navigated to the right drive and folder and ran generateprojectfile.bat, receiving an error (see attached) stating that Unreal couldn’t find a valid version of Visual Studio 2015. Since VS Community 2015 launches successfully, what’s missing here? Thanks for fishing out the thorn.

I just went through that issue myself. To fix

  1. Add C++ to VS2015 Update 2 (and do not upgrade to VS2015 RC3, it has more issues with UE at the moment) you will need to go to the control panel->Programs->VS2015 and change the setup. You need to add the C++ features and common tools. (if you already have those installed, run a repair on VS2015)
  2. As funny as it sounds, you have to also install **VS2013 **(community edition or better) and during the setup, uncheck everything except for the C++
  3. Run GenerateProjectFiles.bat file.
  4. Open the UE4.sln with VS2015
  5. do a “ReBuild” on your project and it should work.

I think that is the bare requirements. If that does not work, goto msdn.microsoft.com and install the standalone Windows 8.1 SDK and Windows 10 SDK

Thanks, Snake.Pliskin, have been in transit, slow to respond. It appears I’ve taken another step back, VS 2015 no longer launches. I ran Repair to no avail. I had support over Microscoft VS forum on that one, should return there once again to straighten that out before then implementing your suggested steps. To note, when I open Programs and Features, I search down through all the C++ files, don’t see C++ Features and Common Tools loaded. Under Programs, selecting VS Studio Community 2015, Change, I don’t see C++ features and common tools, do see Common Tools, but doesn’t make sense this would be the same thing. Common Tools opens to display 3rd party Git files, which I went ahead and added, since I figured UE4 is connected through GitHub, though not clear how that relates to VS Studio. In any event, after the update, I don’t see C++ features and common tools now listed in Programs and Features.

I’ll return to your instructions, should first get VS Community 2015 launching. Thanks.

Now that VS2015 update 3 is officially released (no longer RC 3), it completely breaks UE 4.12! Everything was fine before installing Update 3. And yes Update 3 will remove some of the C++ features that you may have had installed before the update. I did notice that C++ was missing after the update. But even after reinstalling the C++ features, VS2015 update 3 still does not build UE4.12. But I was able to find a workaround, that works

  1. run the command

GenerateProjectFiles.bat -2013

  1. open the project with VS2013
  2. rebuild

oh and if you cant get VS2015 to work even after repairing it. Use this tool by Microsoft to completely uninstall VS2015https://github.com/Microsoft/VisualStudioUninstaller
Then you will have a fresh slate to reinstall VS2015 with.

Thanks for this. I never proceeded to Update 3, but still couldn’t get VS2015 to launch, same error “Cannot find one of more components. Reinstall the program.” I’ll run the uninstaller, run the installer again for VS2015, but then do I pick up with these most recent instructions only, or do I still need to install VS2013 as indicated before “…unchecking everything except for the C++”? Also, before trying to rebuild UE4 into 4.12.2, shouldn’t I validate that VS2015 launches without issues? Also VS2013? Thanks for your help!