Download

Trouble packaging as "Shipping" . . . defaults to "Development"

I’m attempting to upload a variation of Tappy Chicken to Google Play to test the process (as I am new to this) and am receiving the following error:

“upload failed
You uploaded a debuggable APK. For security reasons you need to disable debugging
before it can be published in Google Play. Learn more about debuggable APKs.
You uploaded an APK that was signed in debug mode. You need to sign your APK in release mode.
Learn more about signing.”

I packaged the APK for “Shipping,” trying both Android and Android (ETC1), and have also attempted uploading other packaged projects, receiving the same “Debug Mode” error.
I did obtain a key and sign it as per instructions, and am using 4.2.0.
After searching around, I found this post from May:

“Engine/Source/UnrealBuildTool/Android/UEDeployAndroid.cs ( c# runtime compiled file )
Function: MakeAPK the bForDistribution parameter was always false, even if I ticked for
distribution in the package settings before packaging via the editor.
This was causing the ant build to be called with ‘debug’, and the APK file created in the
compiled manifest as debuggable, and obviously the play store indicated my apk was debuggable,
and couldn’t use it… Also could see it in the build log.”

This sounds like my problem, and my build log also says “for development”, but I haven’t located the file to change this. Any help, please? An aspirin would be nice too.

Read step #3 here: Google Play Setup - Android Development - Unreal Engine Forums

“If the “For distribution” box is checked, UE4 will use the information in SigningConfig.xml to sign the APK, so you’ll need to use those values to get your deployment fingerprint.”

short answer:

Yes, I had generated a key and edited the Signing Config.xml in the project folder. I tried the edited Signing Config.xml in the default system folder Unreal Engine/4.2/Build/Android/Java, as well as the project folder MyProject/Build/Android. And I ticked the “Shipping” box.
The build log still states “Build configuration: Development.”

I only have Shipping and Development as options for the Build Configuration. There is no “Distribution” option in my packaging settings. I suppose the problem has something to do with that.

You need to go into the Packaging Settings window (found in the Packaging menu) and select the “Distribution” checkbox. This will make the .apk be signed with your own key/certificate.

It’s very hidden I agree and also wished it was located within the shipping and development sub-menu

Oh my, thanks! I didn’t see hidden there.:smiley:

This is ■■■■■■■■ you need to sign it with console