Download

Trouble importing tree asset from Max

Good day everyone,

I’ve been following some tutorials on a subscription site, and this particular tutorial detailed building a low poly tree asset specifically for UE4. Unfortunately, the import pipeline wasn’t shown, it was just a simple how to create them for the engine. I followed every step in the creation of the tree, which I’ll outline briefly below.

The problem: When I import the tree into UE4, I seem to be losing over half of my foliage. I’ve attached two images to show the difference in how it looks in Max, and how it’s being viewed in UE4. My only guess is there’s something going on with the foliage normals, backface cull, or something to that effect. The first image is in UE4, and the second is the same angle from Max.

The tree trunk is a cylinder with diffuse, normal, and specular map. The foliage panels are a 3 sided cylinder in the middle (A small branch), with 4 planes that have a leaf texture on them. The texture was made in PS, with the xNormal plugin used to create the normal map, and in the tutorial he made sure to say to change one of the Y directions to Y-. I don’t fully understand why, but I did do that step. The foliage panels have diffuse, specular, opacity, and normal maps. Very importantly: When I applied the foliage panel, I made sure to tick the checkbox marked “2 sided material” in max.

I triangulated the mesh before export, and in the FBX importer I ticked “Smoothing groups” and “Tangents and binormals” as per the FBX Static Mesh Import Pipleline tutorial on the UE4 wiki. I’ve tried to export with a few different settings applied, all to no avail. The next thing I’m going to investigate is the material editor in UE4, as perhaps there’s a 2 sided material option there that I need to tick? I’ll go check that out, but if anyone has any suggestions please let me know!

Thanks

UE4 doesn’t render planes as 2 sided by default, so using a 2 sided material is the right option.

Update: I found the 2 sided material in UE4, and that’s fleshed out the foliage a lot more. But it’s still not the desired effect I’m looking for. I’ve attached another picture which is how it looks now, and the second picture is the example at the end of the tutorial. I know that it’s a material issue at this point, so does anyone have any ideas on how to flesh it out more? I want it to look like tree in the second image. Thanks for any tips or pointers!

Edit: Thanks ZacD for the fast reply. I had typed this out before I saw your post, you ninja’d me. If anyone has any ideas on how to make the first pic look like the second pic, I’m all ears.

You need to re-make the material as a 2-sided material in Unreal Engine. There’s a special pop-up in the material properties where you set this, if I remember correctly.
If you’ve already done that, then there may be differences in where the alpha cut-off happens – it looks like the leaves extend further out in the Max material, so add some processing to your alpha map to make anything above 0.01 yield a 1.0 opacity.
Finally, the difference in color makes the leaves less noticeable. Try darkening the leaf texture (again, some material node math) to match the look from the Max screen shot.

Great suggestions jwatte, thank you! I don’t have much experience with unreal’s material editor, so with your help I’ve achieved the result in the attachment. Can you, or anyone, elaborate on the math needed for the alpha map? I used my diffuse map to make an alpha map (just black and white) to mask out the diffuse map’s background color, but I don’t really understand how to specify a 1.0 opacity on anything greater than a 0.01.

The image below was built using preview quality. Once I can figure out the alpha issues, I’ll try it at production level.