Download

Trouble creating C++ project in UE5 EA

Hey just submitting bug report, I’m having issues creating a c++ project in the EA for ver 5:

Running C:/Program Files/Epic Games/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool/UnrealBuildTool.exe -projectfiles -project=“C:/Users/ghost/Documents/Unreal Projects/MyProject2/MyProject2.uproject” -game -rocket -progress
A fatal error occurred. The required library hostfxr.dll could not be found.
If this is a self-contained application, that library should exist in [C:\Program Files\Epic Games\UE_5.0EA\Engine\Binaries\DotNET\UnrealBuildTool].
If this is a framework-dependent application, install the runtime in the global location [C:\Program Files\dotnet] or use the DOTNET_ROOT environment variable to specify the runtime location or register the runtime location in [HKLM\SOFTWARE\dotnet\Setup\InstalledVersions\x64\InstallLocation].

The .NET Core runtime can be found at:

3 Likes

Adding onto this after installing the new .NET 5.0 SDK, I was prompted to install the .NET 3.1 Core as well:

Fixed the issue and was able to hop into compilation.

4 Likes

Hi
I followed your links, and can confirm these packages allowed for a successful Win64 build. Hats off sir.

To note, I also had to add the following in the Windows environment variables :

DOTNET_ROOT = c:’‘location of dotnet 5 sdk install’’

Let the developing begin :slight_smile:

This fixed the same issue I had. UE5 created a project in blueprint configuration but not in C++ which is what I wanted. Thanks.

Interesting, I installed both the 3.1 and 5.0 SDK and rebooted yet I still cannot create a C++ project, only a blueprints project.
Also verified that both were in the global location listed in the error.

Hello,A low version C++ project cannot be upgraded to a higher version ,Can you give me some advice?

Wow!! It solved!
Saved my day, many thanks!

Elroy

Also, when installing Visual Studio 2019 make sure to enable .NET Windows development. You can do this after the fact by running the installer again. I installed the SDK’s, but they didn’t get recognized (or at least it didn’t work) until I set up VS with .NET development too.