Download

Trouble binding custom ammo to gun

ArkDevKit 236.2
Used the standard bullet and gun for base engrams and primalitem info. and renamed them properly to reflect the custom weapon name. I can see AND build both in-game with the ammo build amount and weapon attributes modified, but the ammo doesn’t bind, or won’t load into the gun for ammo. Any ideas where I went wrong? Okay, wrong question. That’s a needle-in-a-haystack question. Hmm… Lets narrow this down to the basics for now. What is the MOST COMMON reason(s) for this to happen?

Weapon Ammo Item Template correctly set on the weapon BP?

-WM

BP Named: PrimalGameData_BP_Silencer
Have the custom named weapon and ammo as additional engram blueprints.
EngramEntry_SilencerGun and EngramEntry_SilencerBullet

Do you see any issues with the naming conventions?

Common Reasons:
-If the weapons has more than one ammo type, the ammo it may use could have “Drag support onto item class” and “Drag support onto weapon class” make sure your ammo is using the correct drag onto
-The Weapon should be using the ammo in all it’s references
-the PrimalItem should be using the new weapon

If you miss a reference in the Ammo, Item, or Weapon class it will just ignore everything and revert to it’s default, I get it alot when I copy arrows normally it just uses the weapons last mesh or just doesn’t use the correct ammo

Okay, I went through and checked things, made a few changes, still same issue, but, I did find one interesting thing.
The ammo is listed as “Silencer Bullet” and mousing over it reveals the same…word for word…however, mousing over the gun which is supposed to be and labeled “The Silencer” gives the description of “Primitive The Silencer”. Odd? no?

Mod Structure, perhaps this will help.

<Mods>
PrimalGameData_BP_Silencer
Silencer (level)
TestGameMode_Silencer
<Silencer> (this folder is empty, it was from a previous attempt at this mod and if I delete it, so go most of my references. This, may be, in fact, my entire problem although nothing is linked here.)
<SilencerAmmo>
EngramEntry_SilencerBullet
PrimalItemAmmo_SilencerBullet
<SilencerGun>
EngramEntry_SilencerGun
PrimalItem_SilencerGun
Silencer_Icon (Machined pistol)

I’m sure i’m missing something, I just know that its small…but unforgiving…that’s the way these things go in the beginning.

Edit: in the PrimalGameData_BP_Silencer, the value for Default Game Mode is set to TestGameMode_Silencer

Dead folders serve no purpose, just delete them and rebuild the links between the files. The GameMode is not needed, just set it to TestGameMode in your PGD file.

You still didn’t answer my question. On your weapon, have you told it to use your ammo in the field Weapon Ammo Item Template. That needs to point to your new bullet otherwise it won’t use it.

-WM

My apologies for the delayed post. I was trying to reverse my steps. I pulled up the primal info on both base files for machinedpistol and advanced ammo which I used as a base, compared both them side-by-side (really nice that it allows you to do that), and fixed a few things here and there to make them identical and did the same with machinedpistol against my mod. corrected a few things… then, looked at the weapon info in the area you suggested, and got a bit confused. Like everyone else, I have four possibilities.
Support drag onto item class:
Support drag onto item classes:
Ammo support drag onto weapon item weapon template:
Ammo support drag onto weapon item weapon templates:

I’m assuming only the last two fields are relevant. Neither actually shows my mod’ed ammo in the list.

…one step closer…one…step…closer… :slight_smile:

Edit: deleted all the annoying references to the old weapon mod since they kept ‘re-appearing’ after each load of the editor. lost the ammo and weapons files I was working on, but, the folder they were in no longer appears.

The ammo is specified on the blueprint for the Weapon itself, not the PrimalItem file.

-WM

Woeful, any chance you can post a small, cropped image of the exact place you are doing this? I know I sound like a complete idiot right now, but time and time again I simply cannot seem to find these entry points that you speak of and actually have the option of selecting the moded gun/ammo. For example. You say that the ammo is specified in the blueprint for the weapon, and not in the primalitem. Okay, sure…no problem…but the blueprint (read: ENGRAM) for the weapon only shows level needed, points needed to learn etc. It only has…what 4 or 5 places to enter information. The primalitem file for the the weapon, on the other hand, has maaaaany places to enter information. I’m missing something very very basic here and I know I’ve got to be infuriating to those of you that know all of this like the back of your hand…please try to be patient… :slight_smile:

Ok, I think either you’ve misunderstood what is required to make a new weapon, or I’ve misunderstood your intention.

Back to square one, what are you trying to do?

-WM

Okay… I am trying to design a custom pistol that uses custom ammo. Nothing terribly fancy. I dont need to re-colorize them like the rainbow, stock icons are fine. In this case I was trying to use the machinedpistol and advanvedbullet for the weapon and ammo base files. I started with making a folder in the “Mods” directory called “TheSilencer” and as far as I know, I only need the 3 core files, Genericmod (Level), primalgamedata_BP, and test game mode. all renamed “GenericMod_TheSilencer”, “PrimalGameData_BP_TheSilencer”, and"TestGameMode_TheSilencer" in that first main folder. From there I have two subfolders. TheSilencerGun and TheSilencerBullet. The gun/weapon directory has only two files. EngramEntry_TheSilencerPistol and PrimalItem_WeaponTheSilencerPistol. For the ammo folder, the same, only two files. EngramEntry_TheSilencerBullet and PrimalItemAmmo_TheSilencerBullet.

primalgamedata_BP has the engrams for the gun and ammo listed as additional engrams.

Fine.

Incorrect. You only need two of those, the level file which specifies the PrimalGameData and the PrimalGameData file. Just return the GameMode Override in the PrimalGameData to default(little yellow arrow) or change it to point to TestGameMode.

This is your issue. You need to copy the weapon itself(this is not the Engram or PrimalItem file, there is another and it’s icon in the content browser won’t just be blue - it will look like the weapon itself.) to your mod folder and tell the PrimalItem file for your weapon to point to this new file - specified in the Weapon Template field. Furthermore, if you wish for this weapon to be able to accept the attachments like the laser, silencer, etc then you will also need to copy over the files for each of those and correctly re-reference them in your weapon’s files.

This is fine.

-WM

Woeful, you were right. No surprise to you, but, that was the ticket. I found that last file, bound it proper and all I have left to do is iron out the small stuff. Thank you for wading through the mire of my misconceptions. The gun works great!