Download

trouble adding item

i have been trying to get a simple tranquilizer bullet for the one shot rifle to work for the last few days. i can get the round to work when i test it in the editor. the engram show up correctly, it unlocks,crafts, fires, and works as it should. but when i try to test the mod after i cook and upload it. the engram does not show up in game. any thoughts on what could be the problem and how to fix it

Hey Dragon,
Where do you have the engram referenced under the Primal Game Data?
-Mr.Pwndabear

i have it referenced under additional engram blueprint classes at the moment but i have also tried it with it referenced in the normal engram blueprint classes

the engram blueprint for my mod is referenced in the additional engram list of the primal game data. the primal game data is referenced in the world settings of a copy of the generic game mod map. i cook game mod and then upload. when i launch the game and select to run the mod. in the game nothing the engram does not show up. in the editor if i load a test map with the mods primal data in the world settings the engram does show up and work properly. is there some file i am missing for cooking the mod right or is there trick to the structure of the files in the mods folder that’s need to make it work or something else.

Does your pause menu (in actual ark) show the mod loaded?
If not, we both have the same issue that our mod will NOT load in singeplayer nor server.
Its frustrating that theres no fix yet

yea it does not show it as loaded in the pause menu. hmm there has to be way to fix whats causing this

i think i might have found the problem but i don’t know what is causing it. it seems when i cook the game mod it leaves out most of the files for the upload so that its basically an empty mod that gets uploaded. if i go in the arkdevkit/ modtools/output then the folder for my mod nothing is in there for the actual mod.

When you cook this mod, are you cooking it with the map that you made?

Indeed you need to set “Force Load Map Name” of World Settings to TheIsland.


P.S.: You also need to set the PrimalGameData Override. This picture just shows you how to set “TheIsland” right.

In the “Cook/Upload Mod to Steam…” windows you need to set “Maps” to “TheIsland” for all your mods.

b27fbc6532f6ba08fb561c13339f93581d2cd4fe.png

i found changing the name of the map fixed the cooking/upload problem i was having. though now i have a problem where when i go to unlock the engram in game i get this message Fatal error!

ShooterGame.exe!UPrimalItem::GetCraftingResourceRequirement() (0x000000013fadc974) + 586 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalitem.cpp:3296]
ShooterGame.exe!UPrimalItem::InitializeItem() (0x000000013facc3aa) + 10 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalitem.cpp:1933]
ShooterGame.exe!UPrimalItem::AddToInventory() (0x000000013fabe7a9) + 0 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalitem.cpp:459]
ShooterGame.exe!UPrimalInventoryComponent::AddItem() (0x000000013faa8e72) + 0 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalinventorycomponent.cpp:173]
ShooterGame.exe!UPrimalInventoryComponent::IncrementItemTemplateQuantity() (0x000000013fab115b) + 35 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalinventorycomponent.cpp:1417]
ShooterGame.exe!UPrimalInventoryComponent::AddItem() (0x000000013faa8e54) + 0 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\primalinventorycomponent.cpp:169]
ShooterGame.exe!AShooterPlayerState::AddEngramBlueprintToPlayerInventory() (0x000000013fc1edc5) + 35 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\shooterplayerstate.cpp:789]
ShooterGame.exe!AShooterPlayerState::ServerRequestApplyEngramPoints_Implementation() (0x000000013fc1ec13) + 0 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\shooterplayerstate.cpp:764]
ShooterGame.exe!AShooterPlayerState::execServerRequestApplyEngramPoints() (0x000000013ff035ab) + 139 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\classes\shooterplayerstate.h:205]
ShooterGame.exe!UFunction::Invoke() (0x0000000140024f5c) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\coreuobject\private\uobject\class.cpp:3691]
ShooterGame.exe!UObject::ProcessEvent() (0x0000000140071638) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\coreuobject\private\uobject\scriptcore.cpp:907]
ShooterGame.exe!AActor::ProcessEvent() (0x00000001406a058f) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\engine\private\actor.cpp:589]
ShooterGame.exe!UUI_Inventory::ClickedButton() (0x000000013fc8eaa5) + 9 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\private\ui_inventory.cpp:790]
ShooterGame.exe!UPrimalUI::execClickedButton() (0x000000013ff12b1b) + 139 bytes [f:\ue4\unrealengine\projects\shootergame\source\shootergame\classes\primalui.h:15]
ShooterGame.exe!UFunction::Invoke() (0x0000000140024f5c) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\coreuobject\private\uobject\class.cpp:3691]
ShooterGame.exe!UObject::ProcessEvent() (0x0000000140071638) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\coreuobject\private\uobject\scriptcore.cpp:907]
ShooterGame.exe!TMulticastScriptDelegate<FWeakObjectPtr>::ProcessMulticastDelegate<UObject>() (0x000000013f9e0ff0) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\core\public\uobject\scriptdelegates.h:390]
ShooterGame.exe!UButton::SlateHandleClicked() (0x0000000140563474) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\umg\private\components\button.cpp:157]
ShooterGame.exe!TBaseUObjectMethodDelegateInstance_RetVal_NoParams<UButton,FReply>::Execute() (0x0000000140591301) + 11 bytes [f:\ue4\unrealengine\engine\source\runtime\core\public\delegates\delegateinstancesimpl.inl:520]
ShooterGame.exe!SButton::OnMouseButtonUp() (0x00000001401f1f82) + 18 bytes [f:\ue4\unrealengine\engine\source\runtime\slate\private\widgets\input\sbutton.cpp:205]
ShooterGame.exe!FSlateApplication::ProcessMouseButtonUpEvent() (0x000000014014db64) + 23 bytes [f:\ue4\unrealengine\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:3577]
ShooterGame.exe!FSlateApplication::OnMouseUp() (0x000000014014d5e5) + 16 bytes [f:\ue4\unrealengine\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:3541]
ShooterGame.exe!FWindowsApplication::ProcessDeferredMessage() (0x000000013ffca55a) + 12 bytes [f:\ue4\unrealengine\engine\source\runtime\core\private\windows\windowsapplication.cpp:1346]
ShooterGame.exe!FWindowsApplication::DeferMessage() (0x000000013ffcac31) + 74 bytes [f:\ue4\unrealengine\engine\source\runtime\core\private\windows\windowsapplication.cpp:1637]
ShooterGame.exe!FWindowsApplication::ProcessMessage() (0x000000013ffc81d3) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\core\private\windows\windowsapplication.cpp:1043]
ShooterGame.exe!FWindowsApplication::AppWndProc() (0x000000013ffc7677) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\core\private\windows\windowsapplication.cpp:599]
user32.DLL!UnknownFunction (0x0000000077589bd1) + 0 bytes [UnknownFile:0]
user32.DLL!UnknownFunction (0x00000000775898da) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FWindowsPlatformMisc::PumpMessages() (0x000000013ffd79e6) + 41 bytes [f:\ue4\unrealengine\engine\source\runtime\core\private\windows\windowsplatformmisc.cpp:785]
ShooterGame.exe!FEngineLoop::Tick() (0x000000013f9c61dc) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:2288]
ShooterGame.exe!GuardedMain() (0x000000013f9c0b2c) + 0 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\launch.cpp:139]
ShooterGame.exe!GuardedMainWrapper() (0x000000013f9c776a) + 5 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGame.exe!WinMain() (0x000000013f9c7898) + 8 bytes [f:\ue4\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGame.exe!__tmainCRTStartup() (0x00000001418c03a5) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
kernel32.dll!UnknownFunction (0x0000000077685a4d) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00000000777bb831) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00000000777bb831) + 0 bytes [UnknownFile:0]

I’m having this same issue, and I have the force load set and the map set in the upload screen … I only have 1 engram (currently) and 3 items to test but the engram doesn’t show up in my engram list in game :frowning:

Dragon,

When i have seen this error before, the issue was that the item to be crafted by the engram has no crafting requirements (requires no resources.) Check to make sure you have at least one of some resource set there. If that isn’t the issue, double-check all your references to and from the crafted item, as a missing or incorrect reference can cause these fatal errors.

Davetiger,

Have you added your engram to the ‘Additional Engrams’ array in the PrimalGameData file? That will ad your engram to the very bottom of the engram list.

I did not set TheIsland in the Maps section, but it was my name of my Level.

It works fine in SP, i am trying MP later.

I think so … here is the screen shot

It does show up in the editor just not when I cook and upload to the game (singleplayer host)

Same here, after cooking the mod it won’t be loaded into singleplayer game or on server. Set Maps to TheIsland in the Cook/Upload window and also choosed the PirmalGameData Override and Force Load Map Name

somr … here is what I did to fix

First make sure your test map is in your mod folder… then set that test map to use your mod (primal data option if you can’t find I’ll load mine when I get home and send you a screen shot. Set the force override to theisland on the world settings of that map. Then in the cook screen put the name of your map (that is in the mod folder) then cook mod(unless this is a total conversion not sure if it’s different for those). when that’s done upload … now that logs you off of your steam which is fine close steam goto your game folder and goto the folder under game\content\mod? I can’t remember and I’m not home to look. anyway in that folder should be a folder with your mod’s ID (should be at top of steam window when you have the page loaded) DELETE that folder and the id.mod under it. then log back into steam, steam should download the file again… then try it and see if it worked… Let me know if that didn’t work or if you can’t find those places I’ll be home in 9 hours and I can take screens of all these steps

I tried this and it did not work for me… And wouldn’t forcing the mod to “TheIsland” make in incompatible with other maps that are now being released?

Yes, this is old information. Do not have TheIsland as a force load override.

what is the solution to this I am having the same problem and I am leaving the force load field empty should it be anything at all? engrams only showing in SP not online in a server