Download

Trigger volume causing collision problems

Hi there, I’m presently having quite some issues with a trigger volume I have set up, now initially I had no issues and everything worked as intented, but somewhere along the way everything decided to just stop working. What I have is a trigger box that will launch the character upwards if they don’t have a velocity lower than zero essentially giving the player a boost through the doorway.

All of a sudden though it stopped working and now when the player comes into contact with the trigger box they will rapidly bounce up and down as if stuck on the trigger box, and then it will randomly force the player in a direction.

I have tried a few things like recreating the blueprint, recreating the trigger box, and even updating the project to 4.6.1 but the issue still persists.

Here are some pictures that will hopefully provide some help.

Now this first picture just shows how I have the trigger set up, it’s slightly hard to see in this, but it’s very thin and towards the bottom section of that hole.

This second picture shows the blueprint which is present in the character, rather simple and has remained unchanged this whole time, so I know fairly well that it’s not this, and it has worked before.

Also ignore that error under the DoOnce node, that goes away as soon as I compile.
a888d550a60f79ca5253ff8226d0dc49f854d45a.png

Any help would be highly appreciated.

Thanks.

I am still having issues with this, I have copy and pasted the blueprint into another project and it works flawlessly, but as soon as I try in my proper project it just freaks out…