Trigger volume (activating blueprints)

Basically what I would like to achieve is to be able to walk into a trigger and play the kimset. But if I leave the trigger before it plays all of the kismet, the process should stop. Is there any way I could do this? Thanks.


All you’ll want to do is setup a blueprint with a box that is not rendered in game. Setup an event “On BeginOverlap” that triggers something when inside and and “On EndOverlap” that triggers something else or the end of the event.

Thank you!


HI Tim, thanks for your help. I managed to get it to reverse with your answer. The only problem I have now is that even though the kismet plays when I’m on the trigger, once it’s finished and I go off it, the kismet reverses even though the whole animation played. Is there a way to stop the reverse action if I’ve stayed on the trigger for the required time and played it without it going backwards? Cheers.

Maybe something like this? Just add your overlap to the Branch and Set Node (i didn’t want to add a collider etc now. i guess you still get the idea).

If there is a better way (: please tell me! I haven’t tested it on logical bugs.
Maybe it will still call the “Finished” even if you reverse before or something, i don’t know.
Just try it :smiley:

You can get the “Finished” node by selecting the Manitee inside your scene
and selecting “Add MatineeController for …”

This will be called when you Matinee is finished. So be carefull to match the last keyframe with the green zone (green and red arrow at the bottom).

Personally I would set this up using a timeline rather than a matinee unless you have a specific reason to use Matinee.

I’ve attached a zip with the blueprint shown below so you can drag and drop in your scene to test out what I did.

[link text][2]

By using the timeline I can control the rotation much more easily and change values to that need to be adjusted without having to go back into Matinee and redo the work there.


I tried using this example into my own for a test, only problem is that it moves in a bizarre location instead of moving downwards. I believe mine is incorrect to yours but I was just wondering the actions you played in the timeline? Also the target that you have is different to mine, although mine is originally a static mesh, there is animation applied to it and made movable in the settings.

Did you try the I included above?

I had the actual BP I setup with the door and the event graph. It looks like you’re using Level Blueprint rather than just putting your door in a BP by itself. You shouldn’t need crazy values for the Roll and Pitch which looks like you’re offsetting for it’s location possibly?

Try using the BP linked above from the previous post and see if this helps.

If I remember correctly when I set up the Timeline it was just a 0 to 1 value that was 3 seconds long with a cubic break so that it would smoothly open from beginning to end. This was only controlling how the rotation would move not where it would move.

Also, it looks like you’re using relative LOCATION rather than ROTATION. The problem you may be seeing because of this is that with Location you are feeding in a vector that corresponds to a location in 3D space. With the setup above the RInterp is converting a rotation into vector.

Give the above a look and let me know if this helps. :slight_smile: