Trigger volume activates without overlap when enabled

I’m trying to disable my box collision and then enable it after a certain event, but it gets triggered without an overlap instead of just enabling, is there any way to prevent this so it only triggers when I enter it?

Try using the Set Collision Enabled node and set it to no collision. (See attachment)

I think i may have misread that question actually. Have you tried the custom collision settings?

You could try setting the collision of the box to overlap only pawn?