Download

Tried opening my project today after three days and I'm getting a "DX12 is not supported on your system. Try running without the -dx12 or -d3d12 command line argument"

Self-explanatory. I’ve read online that it could be due to some of the marketplace assets that I’ve downloaded or a plugin I’ve enabled in the editor, though it didn’t give me this issue before and everything was working fine.

Now I have Windows 8.1, which I’m aware only supports DX 11.2 and I’ve kept knowingly using it since 2013 as I didn’t want to update to the spyware that is Windows 10. So a few questions:

  1. Is there any reason why the project worked three days ago (and the last year and a half) and never gave me this message before?

  2. Is this due to a recent Epic Games Launcher Update? If so I’ll happily downgrade.

  3. Is there anyway to bypass DX 12 for this project and remove the offending plugins?

Thanks.

Figured it out. Go to your “Unreal Projects” folder then “The name of your project folder” then Config. Open the “DefaultEngine.ini” file and on the line that says:

[/Script/WindowsTargetPlatform.WindowsTargetSettings]
DefaultGraphicsRHI=DefaultGraphicsRHI_DX12

Change “DX12” TO “DX11”

It should open now.

1 Like