Download

Tried everything and Unreal collision does not work

I have a large list of fbx models and I cannot get the collisions to work. I use 3dsmax 2016 to model the objects and I modeled the objects with UCX_name_# and UBX_name_# collisions. I have read the documentation for collision and tried a variety of troubleshooting options. The list of things are as followed:
-In the Import options, I tied checking and unchecking automatically generate collision.
-I updated 3dsmax fbx plug-in and converter plug-in.
-I tried many ways of setting up the collision differently (none give me anything on “Num Collision Primitives” in Unreal’s static mesh editor). I tried using different thicknesses and other recommendations from the documentation and other forum suggestions of other people with the same problem.
-I tired exporting models as an obj file.
-I played with many of the collision options within Unreal (then restored them to default).
-I tried updating Unreal with an updated version.
-I tired exporting from 3dsmax 2017 (I prefer working in 3dmax 2016, however).
-I used the recommended fbx options (enabling: smoothing groups, Tangents and Binormals, embedded media; format: Binary, FBX 2013)
-I made sure collisions aren’t touching each other.
-I made sure they are in the same 3dsmax object layer.
-I’ve tried irregular naming conventions such as UCX_name_0.00#, UCX_name_00#, UBX_name_000_0#, UBX_name.000_0#, UCX_nameA, and UCX_nameA0#.
-I’ve enabled and disabled “One Convex Hull per UCX” with and without auto generate collision in import options.
-I’ve tried converting the collision geometry from editable poly to editable mesh.
-I’ve tried opening the fbx content in an older version of Unreal.

I feel nothing is working, why doesn’t collision work? When I worked in UDK a long time ago it always worked fine. How can I fix this?

:: (UPDATE 09/6/2016) Collision finally fixed due to naming conventions “prop_carrage; UCX_prop_carrage_01; UCX_prop_carrage_02; UCX_prop_carrage_03” …etc. ::

What are you trying to do with the collision and how is it not working?

My objective is simply to block the player from walking into an object. As for how it’s not working, I haven’t got a clue.
I was hoping to have someone else who has had this same problem to help me find a fix. Afterall, I tried everything I could to figure it out and left the forums as my last resort.
Personally, I’m not one to post on forums unless I really need too.

Hey, can you try sharing your fbx that does not work?
I think it will be easier that way

Hmm… What I have not seen in your description is whether you have unticked “One Convex Hull per UCX” on or not.

In my case that helped :smiley:

@KVolger I’m glad it worked for you. However, when I tried it, it didn’t work for me. I’ll add it to the fail list above.
@zeOrb I tried sending you a private message with the complete file to look at, but it says you’re out of space, so i’ll attach it to this post.
http://www.mediafire.com/download/07n2u7gzb238azm/export.zip
If it works, then I can continue with the project. If not, then I’ll keep trying and in the least case scenario I might have to migrate to another engine.

It looks like your collision meshes may have come in as static meshes instead. I would export the fbx out of Max without the collision objects and add 1 or 3 box collison objects in unreal engine since you are just blocking character movement with them…

I might just have to import everything as a static mesh without collision and add a blocking volumes for collision, or find some way to create collision from primitive shapes from Unreal. Either the case, this is ridiculous. I’m beginning to believe it’s my PC or something. I wonder who else is having this problem and how did they fix this.

I use Max and sure it works. Not sure if I’m reading the op right but.

The naming convention should be

Object name = Box
Collision = UCX_Box

When exporting to FBX export by selection only.

There should only be one object for each UCX object.

The object that needs a UCX collision should be a single object and the is not combined when imported.

If you import an object and try to update with a UCX Unreal 4 at times will not update the UCX but only the object. Do a clean import from scratch.

Best practice the UCX can be any number of collision objects but should be combined as a single object.

Easy to test if things are working right.

Make a box and call it “Box”
Make a copy of the box in place and call it UCX_Box.

Select just the two object and export by selection only and should import with collision as a single object.

A tip for making in app custom collision.

Make your custom collision in 3ds Max and export it as a static mesh. In Unreal 4 give it simple collision and in the details check “hide in game”

P.S. I did not see it but make sure combined mesh is unchecked.

Thanks for the lengthy reply; however, I tried following your advice (I tried everything more than once). I simplified the naming conventions. I imported the object with a single collision. I tried importing the FBX model as a staticmesh and as a separate collision which gave me an error message telling me it failed to import. I think what I’m going to try is designing a level then making collision separate using primitives and maybe try using blocking volumes. If it takes too long to use or make in a level, then I’ll migrate and try a different game engine. Although, i’ll be using a different engine, I’ll still try to look for solutions for Unreal.
I’m wondering if it has anything to do with the bach file. Maybe it has stored data of the static mesh somewhere that I should delete.

use collision boxes in Unreal for everything anyway unless you absolutely need it to be per-poly.

The gameplay needs certain items to have perfect collision, because the player will be able to get on top of it. Using my prop carrier as an example, the player will have the ability to get on top if it. It would look strange if they the player were to hover on a box collision on top of it.

I have a huge question that I think could be the source of this issue. Do you think the graphics card could be an issue? I’m using an old Alienware computer with an Nvidia GeForce GTX 295 (update 341.96), (i7 processor, 12.0 GB of RAM, Win x64 bit OS if you want to know the rest). Could a failing or outdated graphics card be the cause of the issue? It has been acting weird for the longest time now.

In my experience when UE4 produces a fail to import error message usually means that the requested asset is not contained with in the FBX file. You can tell the exporter what to export and if export geometry is unchecked you will get this error.

I usually get this error when I set the importer to import animation only and forget to reset for exporting the required elements.

Jeez, this inbox is getting full way too fast. And broken forums did not help either X_X

So, I’ve tried your FBX and I think I found the issue - your actual mesh has incorrect name. After renaming everything went smoothly.
“prop_” is the problem. Naming convention is “%name%” and “UCX_%name%#" and "prop” before mesh name was breaking a connection between UCX’s

@zeOrb Thank you for looking into it; however, I changed every name convention that didn’t require a “prop_” or texture with the “_” character. It still didn’t solve the problem. @FrankieV I tried selecting what to export and played with all the export settings, unfortunately nothing worked.

I’m moving my speculation towards a defective graphics card. My PC’s graphics card is old and sometimes has issues. If physics or game collision has anything to do with the graphics card then I would consider that to be where the problem resides.

@zeOrb, I’m going to allow for a full download of the original asset file. If it’s possible, it would be great if you could take a look at it and see what naming convention is not allowing for the collision to be imported into Unreal.
The object can be downloaded here: http://www.mediafire.com/download/nv2lrgh39oevuxc/prop_carrage.zip

It seems I’m at a stand still. There must be something going on behind the scenes that I can’t seem to fix. I’m guessing it’s my PC or something. I’m about to migrate over to Unity3D and see if I can continue the project there, hopefully, the problem goes away. I’ll probably consider Unreal for my next project. Nevertheless, thank you for your help everyone. I tried.

Right away I noticed that your collision mesh in 3ds max is a bunch of hulls, which would be the reason its not working. Each collision mesh needs to be separated into convex hulls, not being combined. Also, for the naming convention of the collision mesh, each hull is named UCX_FullNameOfMesh_# where as you have UCX_Carrage001, so rather it has to be UCX_prop_carrage_01, UCX_prop_carrage_02, ect for all the individual hulls.
9b3bb2615a9ae5c092e2bc3e134716e70ab5dc08.png

78e486d22cb47e7044fbb21523387d701630293a.png

It worked… It works? IT WORKS!
It works! It works! It works! It works! It works! It works! It works! IT WORKS!!!
4326588.jpg
Thank you so much @Shirk!!!
It looks like I’ll be working in Unreal after all.