Translucent sprites ignore depth(y-order)

As topic says translucent sprites ignore their depth order when tied to other sprites of the same tree.

Hey Distul,

Would you mind providing some screenshots of your issue so I can visualize what you are reporting?

It would be most beneficial if you provided shots of your Translucent Sorting Settings for your individual sprites as well as within the ‘Project Settings’ in the ‘Rendering’ section.

Perhaps some description of what you are attempting to achieve with the translucent sprites and how you are approaching the process? e.g. Is this a Widget Blueprint called to render in World Space or is the sprite physically placed in the world?

Thank you,

I did away with the blueprint I was working on due to the sorting issues.

My settings were as followed:

Rendering > Translucent Sort Policy > Sort Along Axis (X:0 Y:-1 Z:0)

Standard actor blueprint.

When I would attempt to fade the transparency of a sprite the sorting order would vary. Sometimes it would appear in front of other sprites, sometimes not. Their was at least a gap of 20 units between sprites.

However, the problem only seemed to reveal itself when the translucent sprite fell into a tree with other objects. If it were directly under the root component in the blueprint it seemed to work fine.

I’ve attached two photos to clarify.



Hey distul,

This is occurring because you have now adjusted the root of the Sprite which is using that as reference for determining the Depth Order instead of the default Scene root component. If you want to set up depth sorting for your sprites, be sure the ones you wish to sort in order relative to one another, are set up to share the same root.