Translucent material (water) and fog

I have a problem with my water material when the fog is intense, the water are too bright and I don’t know to solve this. Here are a image to ilustrate:

to simplify, this alternative material was used with the same result. Material has all the options by default, less the blend mode set to translucent:

If the material is translucent, then the fog affects to it in that way.
I have touched options, and the only that works is to disable “allow fog”, but then the remedy is worse than the disease… And the material can’t be opaque, it’s the sea, lakes, etc. water.

The fog start distance is set to 0. Setting it to 30000 the result is better, but then the fog doesn’t affect to the near objetcs or the terrain.

There are some way to solve this?

Im not infront of udk now but if you select the mesh,there is a option called translucenty sorting.Try to see if that helps.(value of 1?)Im not sure if fog has the option of translucenty sorting.

there’s a few other options in the material that you could try:

  • EnableSeparateTranslucency (try this one with and also without enabling separate translucency in the systemsettings ini)
  • bUseLitTranslucencyDepthPass
  • bUseLitTranslucencyPostRenderDepthPass
    not guaranteed to work but worth a shot

aside these I don’t think it will be related to translucency sorting as O_and_N suggests

what kind of fog are you using?

No result. The only thing that makes any change is to set on “bUseOnePassLightingOnTranslucency”, the water is about 10% darker, but the borders looks worse, and the performance is the same.

Translucency sorting is set to -1, to solve this problem with the weapon beam: - YouTube
But changing to other values has no effect.

The fog is exponentialheighfog.

The water mesh bright depends of the size of the mesh. It’s a mesh that covers all the playable area, the 10x10 Km. Reducing the mesh scale, the fog bright decreases. Seems some problem with interpolation in the mesh faces.