Translucent material bug - 2D layer order


as i don’t want to describe it, i made a video for you here. Hopefuly you’ll understand.
A little addition…the second bug is solved by moving my box brush background away.

There is so many other bugs in 2D (Orthographic view), some improvement would be nice.

Hey Seeder98,

Try setting the translucent sorting priority so it renders behind the character. Use the image below as a reference.

Translucent Sort Priority

Notice how the sort priority is 0 for this sprite. This is the same for the blue sprite as well. They both are using a translucent material.

Now notice I have set the priority of the green sprite character to -1 and it renders behind the blue sprite character.

Let me know if this works or if you have questions.

Thank you,

Andrew Hurley


thank you for your response, setting translucency priority fixed both, actually. Thanks! Can you explain why is this setting also working with a particle system (Beam), as it has nothing to do with Translucent material.

Thank you again !

You are welcome. Would you mind showing me the material(s) you are using for your particle system?

Specifically the Materials properties and the Editor Graph.


Andrew Hurley

Sure, there it is.

Btw, i was hoping it maybe fixes also not showing up steam and fire particles at all above sprites or background in orthographic view. Well, it does not :frowning:

If you are using a masked material, you will want to add a constant to the opacity mask input so you can use translucency and incorporate that with the Translucent Sort Order.

Let me know if that helps.


Andrew Hurley