Download

Transform Axis Disappeared

Hi…
after i worked some hours in my UE4 project, suddenly i can’t see the Transform Axis Gizmo. Now, i can’t move, rotate, scale any object !! when i open new project Transform Axis Gizmo appear again but it is hard to open new project and import contents again !

is it a bug ? how solve that ?

Top menu bar - Quick Settings- Show Transform Widget.

Failing that, reset the viewport settings - Viewport - Show - Use Defaults.

Following that, reset all settings. Delete the Saved folder in your project folder, and start the editor again.

This option fixed the problem, Thanks Hourences

That one worked for me. Thanks.

Seen a recent bug where (and I am guessing this is 3DSMax’s fault) certain fbx/obj’s imported into the project then dropped into the scene will cause a slew of UI bits to disappear. Including the gizmo, all the title bar text, certain menu options, etc. This is in UE4.21

Thank you this really helped me out. I thought i was screwed xd

Hey, I’m pretty new to Unreal and am having this issue, the axis have disappeared,…cannot fix it…could you expand on this -

'Failing that, reset the viewport settings - Viewport - Show - Use Defaults.

Following that, reset all settings. Delete the Saved folder in your project folder, and start the editor again.’

…I cant see viewport/show/use defaults…where do I find this

what saved folder do you delete…

thanks in adnvance

Ok I got it, thanks, very helpful

Do you know how to fix it?

Sorry, can’t remember if it ever WAS fixed. The issues typically happened on underperformant laptops used by students. Best I can suggest is to reinstall the editor and delete the appdata>local>unrealEngine folder. If that doesn’t work, I imagine the issue is hardware related.

In my case i accidentally pressed 0 (zero)

2nd option did it for me … thanks!

Had the same issue, some how I switched to another viewport.Which did not contain the axis, in the left bottom corner of the viewport.
I got it back by, switching to another viewport.

My solution:
Click on the icon of the “two overlapping monitors” in the right top screen of the viewport.
Once you click on that, depending on your viewport settings, you should see 4 viewports now.

Some might be black, choose whatever viewport and change the camera to perspective, now you will see the axis in that viewport again.
Next maximize this viewport by clicking the top right monitor icon in your viewport.

Now it’s all good for me again! :slight_smile:

3 Likes

Chances are the issue in no longer problematic to the people in this thread but perhaps someone in the future might stumble onto it and, like me, couldn’t find a solution in any of the above.

Happened to me in 4.25.3 so I guess the bug is still lurking around and under the radar.

In order to fix it all I did was navigate to Viewport settings and toggle the Game view. That’s it. Afterwards the gizmo arrows magically came back to life.

Hope it helps.

Screenshot_3.png

5 Likes

#14 worked for me thanks

Wow this worked thank you! It’s always something simple isn’t it. Found that pressing it once gave me the gizmo back but took away the little axis thing in the bottom left corner of the viewport and pressing it again brought it back and kept the main gizmo.

bless your soul! I thought I had to reinstall Unreal…

Hi

This is how my scale looks? :frowning: I have tried both options? any ideas anyone?


2 Likes

I had the same issue and this solved it. Thank you!

you are the legend!