Trackpad Inverted in Unreal Engine 4.22! Any Fix?

Hi everyone.

I upgraded to UE 4.22 this morning and when I loaded into my existing map, my Macbook trackpad is now inverted in the editor.

Has anyone else experienced this problem in the new update? It’s even happening in the blueprint editor.


Me too :frowning:
Didn’t find the solution though

Me too, and believe it or not I do 100% of my development on a macbook trackpad, so this is a very serious problem for me. I’ve changed every option in the editor I can find and nothing fixes it.

Anyone find a fix for this yet or know how we can get some EPIC attention on this?
I opened a ticket on this btw. We’ll see if we get any attention with it.

The feedback so far is that they’ve tried to reproduce it and cannot. I’ve tried it on a clean project and the issue persists.

I just did a check with a MacBook Pro Model A1398 Running HighSierra and did not get a repro.

Please reply here with more information about your Macs to try and help narrow this down…

Thanks for the attention. I’m using A1990 with the specs in the pic.

Same, Mojave here

Any ideas on this ?

So my issue was solved when I did a fresh install, so not just delete and install instead remove the app data Users\YourUserName\AppData\Local\UnrealEngine , it should be work because I believe it is a issue that occurs while installing

As far as I know there is no such path for Macs. like “Users\YourUserName\AppData\Local\UnrealEngine”

I tried deleting everything i could and reinstalling and it did not resolve the issue. Can anyone on a MAC confirm that their issue is resolved?

Have you found a solution yet?

Hello, I got my hands on a Mojave mac, (Macbook Pro A1398) but was unable to reproduce this in a project updated from 4.21 to 4.22.

If you have more detailed repro steps let me know and I’ll give it a shot!

In Editor preferences, search for “scroll” and change the Editor Level - Viewports controls from “natural” to “standard”. This resolved my issue without having to change the scroll direction in the OS.

Hey thanks! This was driving me nuts since by default the engine now has trackpad movements mapped so that a left motion goes right, up goes down, right goes left, down goes up! It’s all backwards by default! I only set the scroll direction for 3D viewports to standard since orthographic viewports seem to work how I expect them to (based on natural scrolling, as set up in the system settings, it just doesn’t make sense applying the same setting to the 3D viewport).

You are a HERO. This was driving me nuts. You have saved my productivity. Thanks