Download

Trace not working on landscape splines

All,
I’m really stuck on this one, hopefully some kind soul can help me out here.

I have a river made with splines. I need to trace down the material so that I can produce the adequate effects (water footsteps, etc). The issue is that either collision does not work, or it works in a way that my character WALKS on the river (doesn’t sink in the water).

All the spline segments have the *SM_MW_WaterPlane *static mesh set on to them:

1b.png

This static mesh SM_MW_WaterPlane has a simple simplified collision box and is set to ignore all collisions, besides the trace on a custom channel called “environment”:

The material of this mesh is set to have water as physical material:

3.png

Now, if I place this static mesh in the world and trace it from the character’s feet with:

Then the trace work BUT I experience what anticipated: my character walks on the spline. If I:

  • Remove the “Enable Collision” on the spline segments.
  • Remove the collision box of the static mesh.

Then the characters sinks in the river as expected, but the trace no longer works.

FYI: if I use the exact same mesh but instead of in a spline, manually set in the world, then everything works as expected: the character sinks in the river and the material of the Out Hit (of the trace here above) is correctly reported as “Water”.

Is this a known feature / bug of splines? How can I circumvent it? Any ideas on how to make this simple thing work?

Thank you,
Roberto.

1 Like

Did you ever find a solution to this? I am going crazy with it too.

1 Like

I ended up using a BP with a Spline component instead.

1 Like

Hey, found a solution for this, which was driving me crazy as well…

Search for this node in all BP - “Add Spline Mesh Component” (for me, it was used in a function within my river spline BP Construction script).

Click this node and adjust collision settings there in the Details panel.

This post tipped me off.

Using these settings, my character could pass thru shallow water and get a hit result from visibility for the surface material.

Seems the collision for a spline mesh can’t be adjusted any other way.