Download

touchpad input issues - acceleration

Hey all,

I’m developing a non-game interactive 3d thing in UE4 for a client, I’m pretty new to UE4 but I thought this would be an ideal platform to learn and develop at the same time. I’m doing this as a Blueprint project as I have no C++ experience.

So the issue is that I’ve got a top down type of movement going on, it’s a 3d map (like Google earth) and I need to control the pan around it with a touchpad (client specified, Logitech t650) but there appears to be some sort of mouse acceleration happening inside of UE4. When I do long slow movements with my finger across the touchpad, I get large movements in UE4 but when I do rapid, smaller movements (like you’d naturally do if you want to navigate around quicker) I actually get a decrease in movement speed.
What I’d like to happen is that quicker mouse (touchpad) inputs result in more motion than the longer/slower mouse (touchpad) inputs allow for slower, more precise control.

So the things I’ve tried so far are;

  • Disabled all Windows mouse acceleration/smoothing
  • Disabled any Logitech Touchpad driver acceleration
  • Adjusted the mouse sensitivity value in UE4 project input settings
  • Adjusted the mouse exponent value in UE4 project input settings
  • Created a timer Blueprint function in my pawn which multiplied the axis values when quick inputs are detected (didn’t really work well but I might not have done a very good job)
  • Clamped the input values (from -1.0 to 1.0) in the pawn blueprint movement control

Does anyone have any suggestions of how I can get around this issue? It’s fundamental to the success of my project as if I cannot overcome this, I will have to go back to my client with a suitable alternative - but they are dead set on a (non-screen) touch interface.

Cheers,
Rob